Search Unity

  1. Unity 2018.1 has arrived! Read about it here
    Dismiss Notice
  2. Scriptable Render Pipeline improvements, Texture Mipmap Streaming, and more! Check out what we have in store for you in the 2018.2 Beta.
    Dismiss Notice
  3. If you couldn't join the live stream, take a peek at what you missed.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  5. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  6. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Audio in Timeline is not respecting 2D vs 3D audio source values

Discussion in 'Timeline' started by jmguillemette, Sep 19, 2017.

  1. jmguillemette

    jmguillemette

    Joined:
    Mar 4, 2015
    Posts:
    17
    All audio played via Timeline is played as 3D audio. This results in audio that shifts from left to right and in volume even when the audio source is set to 2d and is attached to the camera.

    I'm trying to build a missing briefing sequence and this is resulting in audio fading and shifting where the desired audio should be consistent and mono.

    if I've missed a setting... I welcome any help anyone can suggest.

    j.
     
    P_Jong likes this.
  2. mikew_unity

    mikew_unity

    Unity Technologies

    Joined:
    Sep 27, 2016
    Posts:
    76
    point the audio track to an audio source in your scene and then you have full controller whether it's a 2d sound versus 3d w/ positional information.
     
  3. Artline

    Artline

    Joined:
    Feb 21, 2017
    Posts:
    3
    Did you find any solution to this?

    I have the same problem. I want to add music to a timeline and control the volume but if I add an audio source 2d to timeline the music sound in 3d anyway.
     
    P_Jong likes this.
  4. P_Jong

    P_Jong

    Joined:
    Jun 14, 2017
    Posts:
    12
    This is for certain a bug. My timeline does not even have an audio source attached. Yet I'm experiencing the following:
    My timeline has a track that activates an object with an audio source set to 2D spatial blend and play on awake . My timeline does not even have an audio source component. Yet sound is coming from the timeline and not the object just activated. And it is always set to 3D. Right now I'm having to move the timeline location to the player so they can hear. The desired outcome is timelines should not be an audio source. The audio source should be from the object being activated by the timeline. @mikew_unity
     
  5. DoctorShinobi

    DoctorShinobi

    Joined:
    Oct 5, 2012
    Posts:
    50
    Hey, just found this thread because I also have this bug. This occurs using Unity 2018.1.0f2
    Edit : My track is also referencing an audio source that has Spatial Blend fully set to 0(2D)
     
    P_Jong likes this.
  6. sevensails

    sevensails

    Joined:
    Aug 22, 2013
    Posts:
    481
    I have a similar bug. Changing the Audio Source Volume is not working as expected. The Audio Track is linked to a Audio Source on my scene, but the changes on Audio Source Properties (Volume or any other) does not reflect on the Audio being played on timeline.
    Using Unity 2018.1.f2
     
    P_Jong likes this.
  7. sevensails

    sevensails

    Joined:
    Aug 22, 2013
    Posts:
    481
    @mikew_unity Please, tell me that there is some workaround for this Audio Volume problem with Time Line. I need to generate a final build very soon, and need this to be fixed.
     
    P_Jong likes this.
  8. DoctorShinobi

    DoctorShinobi

    Joined:
    Oct 5, 2012
    Posts:
    50
    If you need to generate a final build very soon then don't wait for Unity to fix it. Create your own track/clip/mixer that plays an audio source directly from reference. That's what I did and it works for the time being.
     
  9. Fsora

    Fsora

    Joined:
    May 18, 2017
    Posts:
    1
    I have this bug too in 2018.1.1f1,but my problem is I can't play a 3D sound.
    Out of max distance, I still hearing the sound
     
    mgeorgedeveloper likes this.
  10. mgeorgedeveloper

    mgeorgedeveloper

    Joined:
    Jul 10, 2012
    Posts:
    40
    @Fsora correct - my audio source is set to fully 3D, and I can see the listener distance being tracked on it in play mode, but it makes NO DIFFERENCE to the volume when Timeline is playing clips through that audio source. It's 100% a bug.

    @mikew_unity any chance you can look into this? I can't easily report a reproducable bug with a 30GB project. I'm pretty sure this is happening to everyone.

    EDIT: some more information - basically, the audio source you attach to the track is ignored. It is as if a new audio source is dynamically created at co-ordinates (0,0,0) and this audio source is set to 3D, with a very long range. I came to this conclusion by placing an audio listener at (0,0,0) in the scene, and then moving it around in play mode to see how it reacts to the audio track in Timeline. So, there's a bug where the audio source on your Timeline track is ignored, and instead a default, dynamically created one is used (my guess is, some code was added to create some kind of default audio source if none is attached to the track, but the code has a bug).

    EDIT 2: well, it's behaving "as if" an audio source is created, but it's still seemingly using the audio source you attached, but bypassing every single setting + the distance from it (for 3D audio).
     
    Last edited: May 31, 2018
    SpencerPDX likes this.
  11. SpencerPDX

    SpencerPDX

    Joined:
    Jan 3, 2012
    Posts:
    124
    mgeorgedeveloper likes this.
  12. mgeorgedeveloper

    mgeorgedeveloper

    Joined:
    Jul 10, 2012
    Posts:
    40
    Hi, do you have a link to the bug report page? This thread seems kind of dead.
     
  13. SpencerPDX

    SpencerPDX

    Joined:
    Jan 3, 2012
    Posts:
    124