Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Asset Store Broken or is it me?

Discussion in 'Assets and Asset Store' started by UdiHrant, Nov 9, 2011.

  1. UdiHrant

    UdiHrant

    Joined:
    Nov 8, 2011
    Posts:
    2
    I'm new to Unity. there is an in-app portal to the Asset STore that I can never seem to get to work. Is it broken or is it me?
     
  2. sybixsus2

    sybixsus2

    Joined:
    Feb 16, 2009
    Posts:
    943
    How long are you giving it to load? I'm on a 16mbps line and it takes a couple of minutes to even load the home page.
     
  3. Alienchild

    Alienchild

    Joined:
    Oct 14, 2010
    Posts:
    364
    It's broken by design.
     
  4. tertle

    tertle

    Joined:
    Jan 25, 2011
    Posts:
    3,734
    If I alt tab while asset store is loading, unity locks up for me. But if I'm patient and let it load it boots up pretty quick.
     
  5. sybixsus2

    sybixsus2

    Joined:
    Feb 16, 2009
    Posts:
    943
    Aye, alt-tabbing definitely causes problems and it's very tempting to do it when it takes so long (for me, anyway). The window stays there after you close it once it's frozen, and it prevents the console from opening properly. Eventually, you're forced to shut it down because the store window is preventing the run button from even working. It's pretty sad that all the store problems have been ignored for so long.
     
  6. lasse

    lasse

    Unity Technologies

    Joined:
    Oct 26, 2011
    Posts:
    52
    UdiHrant: We'll need some more details to go on... What happens when you open the asset store in the editor? Does it load slowly, partially or not at all?

    sybixsus2: I can't seem to find a bug report matching your description... Do you have a case number you can send me?

    The store usually loads in a few seconds for me - 15 seconds tops (and no, we don't sit closer to the servers)... How many packages do you have in the download manager?
     
  7. tra2002

    tra2002

    Joined:
    May 11, 2011
    Posts:
    142
    I have open the asset store on my laptop and is always slow and seems to crash unity when i alt tab while waiting. This can be just to load windows explorer or browser for example. If I just minimize unity it still is fine as long as I do not load other software. But, on my desktop the asset store is slow loading and when it does load the images still will take some time to finish loading but I can alt tab just fine and wait for it to load. Once it is all loaded everything runs just fine on both machines.

    Laptop specs
    Windows Vista
    Notebook: HP Pavilion dv9000
    Processor: Intel Core 2 Duo T7400
    Samsung 4GB Ram
    Graphics Adapter: NVIDIA GeForce Go 7600 128 MB

    Desktop specs
    Windows 7
    EVGA X58 SLI Motherboard
    Intel Core i7 980X CPU
    Corsair 12GB RAM
    (2)EVGA GTX 580 Superclocked
    (1)EVGA GTX 460 SuperClocked (dedicated physics)
     
  8. andorov

    andorov

    Joined:
    Feb 10, 2011
    Posts:
    1,061
    On my machines, the asset store doesn't appear to be threaded. It seems like its making blocking calls to the server, so if I open it and the server is having connectivity issues (which it does... alot), it will block Unity till it clears up.

    I can usually get it to work, but its not pretty.