Search Unity

Artifacts after I baking Lightmaps

Discussion in 'General Graphics' started by scr33ner, May 6, 2021.

  1. scr33ner

    scr33ner

    Joined:
    May 15, 2012
    Posts:
    158
    I'm getting artifacts after I bake my scene. They are prominent when you walk close to the building, otherwise they don't show. How can I ensure this isn't happening? I generated UV lightmaps for all my mesh during import.
    artifacts.png
    Bake Settings:
    bakeSet.png

    Quality settings:
    qualitySet.png

    UV lightmap settings
    uvLightMaps.png
    Thanks in advance
     
  2. BrandyStarbrite

    BrandyStarbrite

    Joined:
    Aug 4, 2013
    Posts:
    1,906
    @scr33ner
    In the material of the mesh, enable double sided illumination. Hopefully, that works.
     
  3. scr33ner

    scr33ner

    Joined:
    May 15, 2012
    Posts:
    158
    Thanks will give it a go
     
    BrandyStarbrite likes this.
  4. BrandyStarbrite

    BrandyStarbrite

    Joined:
    Aug 4, 2013
    Posts:
    1,906
    Alright.:D
     
    Last edited: Sep 19, 2021
unityunity