Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

ARKit on iPhone 8 issues

Discussion in 'AR' started by ifeltdave, Nov 14, 2017.

  1. ifeltdave

    ifeltdave

    Joined:
    Aug 28, 2012
    Posts:
    16
    [SOLVED] A stupid issue. He had to restart his phone and voila. Tracking. We found this was an issue by trying other AR apps which also did not work.

    No idea why, but hey.. I don't ask questions.

    Orig post:

    Has anyone else had issues with builds on iPhone 8+?

    I have a device running os 11.1.1, an iPhone 8+, and the experience never gets past the tracking stage. I never see the point cloud dots render on my surface, and a plane is never anchored to the world.

    The experience works great on iPhone 7, os 11.0.3. I updated my UnityARKit plugin (I saw an update was available and hoped this was the cause) but still no luck on iPhone 8+. I haven't been able to test on a base iPhone 8 yet.

    I'm hesitant to upgrade my iPhone 7 in case this is an 11.1.1 issue. More investigating is needed there, but in the meantime I wanted to know if anyone else had these issues specifically on iPhone8+.
     
    Last edited: Nov 14, 2017
  2. Dev_Sebas

    Dev_Sebas

    Joined:
    Jul 10, 2014
    Posts:
    19
    I had the same issue yesterday, went testing my ARKIT scenes and no point cloud available, my tracking character appeared on a wall far away, tried multiple times and same results. Then realised that any app using ARKIT also didn't work. Began to think that camera or gyroscope sensor died.
    But restarted and it´s everything working as before.

    This on my i8+ on 11.1.
    Seems a random bug

    Cheers
    Seb