Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Resolved [ARKit Face Tracking] ld: 10 duplicate symbols for architecture arm64

Discussion in 'AR' started by OriginTag, Feb 4, 2020.

Thread Status:
Not open for further replies.
  1. OriginTag

    OriginTag

    Joined:
    Jul 24, 2019
    Posts:
    1
    Hi,
    I had ARKit XR Plugin installed before for different AR scenes and everything worked well. When I wanted to add face tracking to my application I installed ARKit Face Tracking package. It builds in Unity, but during building in XCode, I have an error:

    duplicate symbol 'malloc_allocator::deallocate(void*)' in:
    Libraries/com.unity.xr.arkit-face-tracking/Runtime/iOS/libUnityARKitFaceTracking.a(malloc_allocator.o)
    Libraries/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a(malloc_allocator.o)
    duplicate symbol 'malloc_allocator::allocate(unsigned long, unsigned long)' in:
    Libraries/com.unity.xr.arkit-face-tracking/Runtime/iOS/libUnityARKitFaceTracking.a(malloc_allocator.o)
    Libraries/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a(malloc_allocator.o)
    duplicate symbol 'stack_allocator::get_config()' in:
    Libraries/com.unity.xr.arkit-face-tracking/Runtime/iOS/libUnityARKitFaceTracking.a(ARKitXRFaceProvider.o)
    Libraries/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a(AllocatorConfig.o)
    duplicate symbol 'stack_allocator::deallocate(void*)' in:
    Libraries/com.unity.xr.arkit-face-tracking/Runtime/iOS/libUnityARKitFaceTracking.a(stack_allocator.o)
    Libraries/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a(stack_allocator.o)
    duplicate symbol 'stack_allocator::allocate(unsigned long, unsigned long)' in:
    Libraries/com.unity.xr.arkit-face-tracking/Runtime/iOS/libUnityARKitFaceTracking.a(stack_allocator.o)
    Libraries/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a(stack_allocator.o)
    ld: 10 duplicate symbols for architecture arm64

    I am using Unity 2018.4.5f1 with AR packages:
    AR Foundation 1.5.0. preview.6
    ARCore XR Plugin 2.2.0 preview.2
    ARKit XR Plugin 2.2.0 preview.5
    ARKit Face Tracking 1.1.0 - preview 5

    When I create a clean project and install same packages I have no problem building at all. Any ideas where to find a cause of my problem and fix it?
     
    WestSoldier and patpre like this.
  2. AndyMorrin

    AndyMorrin

    Joined:
    Aug 2, 2017
    Posts:
    4
    Hey did you manage to solve this problem?
     
  3. patpre

    patpre

    Joined:
    Jan 12, 2021
    Posts:
    26
    Quite long time ago… and now I am using completely different versions of packages (ARKit, etc.) and unity… but I think it was caused by an external sdk I used… hope that helps…
     
Thread Status:
Not open for further replies.