Search Unity

ARFundation and video (known issue)

Discussion in 'Handheld AR' started by Balours, Sep 18, 2018.

  1. Balours

    Balours

    Joined:
    Nov 27, 2013
    Posts:
    46
    Hi all,

    Can we please get an update on one issue in ARFundation:
    https://github.com/Unity-Technologies/arfoundation-samples/issues/7

    Native video player and all other video players from the asset store are not working. If there is a workaround before the official fix I will be very happy :)

    If there is no workaround, is there any ETA about the official fix?

    Thank you,
     
  2. tdmowrer

    tdmowrer

    Unity Technologies

    Joined:
    Apr 21, 2017
    Posts:
    547
    We are testing a potential fix. If that solves the problem, we will push an updated package soon.
     
    Balours likes this.
  3. tdmowrer

    tdmowrer

    Unity Technologies

    Joined:
    Apr 21, 2017
    Posts:
    547
    This has been fixed in the latest ARCore package: 1.0.0-preview.19. I've updated the samples repo to point to that version. Let me know if you continue to see any issues with the video player.
     
    nilsdr and Balours like this.
  4. Balours

    Balours

    Joined:
    Nov 27, 2013
    Posts:
    46
    Hi @tdmowrer ,
    It works for me! Tested on Unity 2018.2.7f1.
    Thank you for the fix!
     
  5. M1tiens

    M1tiens

    Joined:
    Jun 1, 2017
    Posts:
    2
    Hi @tdmowrer

    I'm trying to play video with ArFoundation on Android. I'm adding the video player to a canvas with a raw image inside. If i press play on the editor i can see the video rendered and playing on the canvas, but when i build and run and try on the device is not working. I'm using Unity 2018.3.12f1 and using ArFoundation 1.0.0 preview 22 and ArCore 1.0.0 preview 24.

    Thanks in advance.