Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug ARFoundation docs and AR samples git hub are stating contradictory version requirements.

Discussion in 'AR' started by svenneve, Sep 28, 2023.

  1. svenneve

    svenneve

    Joined:
    May 14, 2013
    Posts:
    79
    We are trying to figure out which AR foundation version goes with which ar foundation samples version.
    The problem is the AR Foundation docs claim vastly different editor version requirements than the github samples claim AR Foundation requires.

    Does anyone know which one is the correct version and which version of ARF goes with which samples?
    So far anything above ARF 4 and samples seem to be broken or incompatible.
     

    Attached Files:

  2. jakem_unity

    jakem_unity

    Unity Technologies

    Joined:
    Feb 14, 2023
    Posts:
    7
    It's because those are two different pieces of information. The one in the drop down on the docs page is the minimum supported version of the editor that AR Foundation will work, but the one in samples is the verified editor version for the package. That means that when you open that particular Unity editor version, the version of AR Foundation you will see in the package manager will be what is displayed in the samples project. You can change the version of packages though through the manifest if you want.

    You can read more about it here https://docs.unity3d.com/Packages/c...project-setup/edit-your-project-manifest.html
     
    andyb-unity likes this.