Search Unity

ARCore SDK Preview 2 is encountered a problem connecting. please start the app again.

Discussion in 'ARCore' started by nandonandito, Dec 17, 2017.

  1. nandonandito

    nandonandito

    Joined:
    Nov 24, 2016
    Posts:
    37
    hi, my names Nando and im test the new SDK Preview 2 from ARCore SDK at github.
    but the problem i got after i build and install it on devices the problem is "arcore encountered a problem connecting. please start the app again." somebody have the same problem?
    i test to build this project is using unity 2017.2.1f1 and test it to galaxy s8.
    i try to downgrade using the previous SDK Preview its still work, but if i update to SDK Preview 2, i get this problem. thankyou so much.
     
  2. chaosemer

    chaosemer

    Official Google Employee

    Joined:
    Jul 5, 2017
    Posts:
    21
    SDK Preview 2 requires Unity 2017.3.0f2 or higher. You can get 2017.3 at unity3d.com/beta.
     
  3. saruhanm

    saruhanm

    Joined:
    Dec 27, 2016
    Posts:
    1
    Hi, I am getting the same error with 2017.3.0f2. I just opened new project. Installed new arcore package(2) and build HelloAR example project.Please test something before publishing. Phone is SM-G950U1
     
  4. nandonandito

    nandonandito

    Joined:
    Nov 24, 2016
    Posts:
    37
    ok, i would to try and download this again.. thankyou so much.. i hope its better than the previous version.. because the previous version for tracking object.. and thats why, i really need to update with sdk preview 2
     
  5. nandonandito

    nandonandito

    Joined:
    Nov 24, 2016
    Posts:
    37
    hi, after i updated my unity to unity 2017.3.0f2 i still get thats error.. same like before
     
  6. thanhit08

    thanhit08

    Joined:
    Mar 14, 2014
    Posts:
    4
    same problem...
     
  7. thanhit08

    thanhit08

    Joined:
    Mar 14, 2014
    Posts:
    4
  8. nandonandito

    nandonandito

    Joined:
    Nov 24, 2016
    Posts:
    37
    yes, i actually i do the same way.. but the problem is about the sdk version.. if im using the sdk preview the first version it works and i dont get any problem.. but after i update the new version sdk version 2 its doesn't work.. i can't play it on my device.
     
  9. nandonandito

    nandonandito

    Joined:
    Nov 24, 2016
    Posts:
    37
    there's still get the problem with this? im still getting error..
     
  10. Superdeath

    Superdeath

    Joined:
    Nov 6, 2013
    Posts:
    1
    One thing you may run into - if you install a new version of Unity but keep an old shortcut in your taskbar, say, the shortcut may continue to point at the old version. Make absolutely sure you're running 2017.3 by clicking Help>About Unity. If you aren't, it will cause this issue.
     
  11. luisforque

    luisforque

    Joined:
    Nov 25, 2014
    Posts:
    8
    Make note that you need to have the arcore-preview2.apk installed on the device, instead of the previous one.
     
  12. Vivivi

    Vivivi

    Joined:
    Jan 14, 2018
    Posts:
    1
    Hi, have you succeed? I have the same error, too. I think that maybe it's the arcore.apk's problem or something. I tested the demo on two different pc and different OS but got the same error.
     
  13. nafem

    nafem

    Joined:
    Dec 18, 2017
    Posts:
    1
    I have this issue with arcore-preview2.apk as well. Anyone have any luck with it?
     
  14. MrMatthias

    MrMatthias

    Joined:
    Sep 18, 2012
    Posts:
    150
    yes, build with 2017.3.0p2
     
  15. bergstone

    bergstone

    Joined:
    Feb 5, 2018
    Posts:
    1
    I had the same problem, but I have made few mistakes by setting up the project:
    1. I had an old version of Android SDK (API version 23), I have updated it under Android Studio to API24.
    2. I forgot to install ARCore on my device(Samsung Galaxy S8):
    • Install ARCore on the device:
      • Download arcore-preview2.apk
      • Connect your Android device to the development machine with a USB cable
      • Install ARCore by running the following adb command:
        adb install -r -d arcore-preview2.apk
    3. I didn't didn't correctly the build settings under Unity:
    • Other Settings > Multithreaded Rendering: Off
    • Other Settings > Package Name: a unique app ID that looks like a Java package name, such as com.example.helloAR
    • Other Settings > Minimum API Level: Android 7.0 or higher
    • Other Settings > Target API Level: Android 7.0 or 7.1
    • XR Settings > ARCore Supported: On
    After configuring again all above settings my demo app is working.
     
  16. ramphulneillpartners

    ramphulneillpartners

    Joined:
    Jul 30, 2017
    Posts:
    7
  17. chaosemer

    chaosemer

    Official Google Employee

    Joined:
    Jul 5, 2017
    Posts:
    21
    Augmented Faces does not work on the Back Camera at the moment. It only is supported on the Front Camera.
     
  18. ramphulneillpartners

    ramphulneillpartners

    Joined:
    Jul 30, 2017
    Posts:
    7
    Thank you.

    Why does Augmented Faces not work on rear view camera?

    It would seem really easy to implement this. I have spent the last week trying to work around this with limited success, (changing Vector2 ImageSize, Vector2TextureSize's, camera configuration database, etc).

    Many thanks again,

    tim