Search Unity

  1. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  2. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  3. Participate with students all over the world and build projects to teach people. Join now!
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

ARcore no longer finding surfaces (it did, but now doesn’t ?!?)

Discussion in 'AR/VR (XR) Discussion' started by Richard3575, Dec 5, 2018.

  1. Richard3575

    Richard3575

    Joined:
    Dec 5, 2017
    Posts:
    1
    Hi,

    Anyone noticed ARCore not being able to find surfaces?

    We’ve been dabbling with ARcore for a few months and it’s been working well. It’s found surfaces pretty quickly and gets a stable lock on them.

    However, in the last few weeks it’s turned to complete unusable rubbish.
    • It cannot find a stable plane (white grid) – looking at the exact same surface we did the day before. (tried moving he phone around slowly, holding still, adding more items to the floor to create more pattern, etc. Tried for over 3-4 minutes, and still nothing)
    • It only just finds a few dodgy surfaces, red/purple/blue which then float around as we move.
    • Nothing had changed in our build.
    • Tested on a clean Unity project with a clean install of *arcore-unity-sdk-v1.5.0.unitypackage* – same effect.
    • At first we thought this was as our test device (Sony Xperia XZ premium) which had updated to Android 9.0. We thought this might be the issue. However we’ve tested on a Samsung Tab3 with Android 8.0 and we get the same issues. (note, this is a new device and did not test before hand on it)

    To stress – these were NOT issues a few weeks ago, everything worked remarkably well without any issue.

    We’re baffled why this it – nothing else has changed. We’ve done baseline tests and still ARcore has reverted to being utterly unusable.

    Has anyone experienced anything similar? Or any ideas why this might be?

    Any help is greatly appreciated.

    Thanks,