Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

ARCore Instant Preview: Tested App is not showing on Smartphone

Discussion in 'ARCore' started by noseriousname, Aug 21, 2019.

  1. noseriousname

    noseriousname

    Joined:
    Dec 23, 2018
    Posts:
    1
    Hey folks,

    i've been learning to use ARCore for a while and it worked fine. Now, i have a new PC and tried out some of my projects i've done before. Generally, ARCore still works, except the Instant Preview. Well, the Preview-App is starting and streaming to my Unity Editor, Camera feed is shown in Editor, tracking is done. But on my Smartphone itself, the actually previewed App is not visible (as it was before when working on my old PC).

    Funny about is, that the App is processing Touch-Inputs from the Smartphone: So, as it is tracking planes (which i can see in Unity Editor) i can tap on my Smartphonescreen and set a GameObject for example. But all it shows is the UI of the Instant Preview-App (not a black screen or kind; just not what i can see in Editor Preview as its been on my old PC).

    I have no clue what to do now. Tried same Unity Version i used on my old PC (Unity 2019.1.3f1) as well as a later Build (2019.2.1f1), reinstalled Preview-App and reimported ARCore SDK, Multiplayer HLAPI and XR Legacy Input Helper. I also tried out with a new project, same issue.

    Any ideas what i could do next? Any further informations you need for help?

    Thanks for any help or at least for reading :)