Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question arcore extensions requires AR session origin, but won't accept XR Origin

Discussion in 'AR' started by Finn_Nua, Dec 1, 2023.

  1. Finn_Nua

    Finn_Nua

    Joined:
    Mar 27, 2023
    Posts:
    9
    Hi there. I'm setting up a project to use the geospatial API. I've added the AR session, arcore extensions and XR origin to my hierarchy.

    Problem is, arcore extensions is looking for AR session origin and won't accept the XR origin.

    I've tried to build it but the build is just stalled and going nowhere (still building after 30mins and doesn't seem to be progressing).

    How do I add the XR origin to arcore extensions and could this be causing the build to stall?
     
    jason_unity999 likes this.
  2. andyb-unity

    andyb-unity

    Unity Technologies

    Joined:
    Feb 10, 2022
    Posts:
    989
  3. mohammadjilan333

    mohammadjilan333

    Joined:
    Dec 30, 2023
    Posts:
    1
    heyy finn!, did you manage to find any solutions? actually I'm stuck with the same issue
     
  4. andyb-unity

    andyb-unity

    Unity Technologies

    Joined:
    Feb 10, 2022
    Posts:
    989
  5. WTFusername

    WTFusername

    Joined:
    Aug 13, 2018
    Posts:
    2
    1. ARCore Extensions for Unity's AR Foundation uses the ARCORE_USE_ARF_5 Custom scripting symbol to determine version compatibility. For AR Foundation 5.x compatibility, add the ARCORE_USE_ARF_5 Custom scripting symbol:
      1. In Edit > Project Settings > Player > Other Settings, scroll down to Script Compilation.
      2. Use the + button to add ARCORE_USE_ARF_5.
      3. Select Apply.
    I solved it with this
    Thx andyb
     
    andyb-unity likes this.