Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Bug AR Foundation 5.0.7 Image Tracking - place prefab then suddenly it switches to front cam by itself

Discussion in 'AR' started by newguy123, Aug 16, 2023.

  1. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    1,281
    I have a very weird issue suddenly that came up, after switching from 5.0.5, to 5.0.7.
    This alone could possibly not be the issue, but I havent touched the "AR" part of my code or the project since and I've only been adding model prefabs to add to the scene.

    So I start the AR experience, it scans the image target, then as soon as it detects the image, it places my prefab, but then suddenly for no reason my iPad Pro M2 switches to front cam, which it did not do a month ago.

    Any ideas what is going on and how to prevent it?
     
  2. newguy123

    newguy123

    Joined:
    Aug 22, 2018
    Posts:
    1,281
    Yes seems some kind of bug
    Only thing I did now was roll back to 5.0.5 from 5.0.7, and now it seems to work as it should again.

    So in my case 5.0.7 messes something up it would seem.
     
  3. unity_andrewc

    unity_andrewc

    Unity Technologies

    Joined:
    Dec 14, 2015
    Posts:
    230
    andyb-unity likes this.