Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Application crashed when executing "SpatialMappingManager.Instance.DrawVisualMeshes = false"

Discussion in 'VR' started by shuiliuli, Aug 10, 2016.

  1. shuiliuli

    shuiliuli

    Joined:
    Aug 10, 2016
    Posts:
    2
    Application crashed when executing "SpatialMappingManager.Instance.DrawVisualMeshes = false" in my scene.
    What can I do for this?Does anyone get it?
     
  2. dwmsco

    dwmsco

    Joined:
    Nov 6, 2014
    Posts:
    13
    I disable the drawing of visual meshes in projects all the time. Can you give a bit more info on what you're doing?
     
  3. BrandonFogerty

    BrandonFogerty

    Unity Technologies

    Joined:
    Jan 29, 2016
    Posts:
    83
    Hi @shuiliuli

    How are you creating your spatial mapped mesh? Are you using the SurfaceObserver API directly or are you using our builtin spatial mapping component?

    Do you have a simple repro project that we can look at?

    Thanks!
     
  4. shuiliuli

    shuiliuli

    Joined:
    Aug 10, 2016
    Posts:
    2
    Thanks for your replies, I am trying it in a simple scene.
    In my current scene,I use "SpatialMappingManager.Instance.DrawVisualMeshes = true" to create the spatial mapped mesh When start();
    Next,execute "GameObject.Instantiate(Resources.Load("");" to load models.
    After loading, execute "SpatialMappingManager.Instance.DrawVisualMeshes = false",and then tha application crashed.