Search Unity

  1. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Apple store rejected the app because of the TruDepth API

Discussion in 'AR/VR (XR) Discussion' started by Futurristic, Sep 28, 2019.

  1. Futurristic

    Futurristic

    Joined:
    Jun 21, 2016
    Posts:
    37
    Hi,

    I'm trying to release the Arkit app to the apple store, but was rejected for the below reason.

    If your app does not include any features that use TrueDepth APIs, please remove them from your app.

    If your app uses the Unity ARKit plugin, it would be appropriate to update to the latest version, which includes a setting that allows you to exclude TrueDepth APIs.

    Below are the details of various packages used

    Unity. - 19.1.0f2
    Arkit XR - 2.1.0 preview 5
    Arfoundation - 2.1.0 preview 3
    Arkit face tracking - 1.0.0 preview6
    LWRP - 5.6.1

    Can anyone pls help here.

    thanks
     
    Pixygon likes this.
  2. Pixygon

    Pixygon

    Joined:
    May 9, 2013
    Posts:
    21
    It is because of the ARKit Face Tracking package! If you aren't using facetracking, just remove the package and it should work :) Also, ARFoundation 3.0.0 has a lot better support for LWRP, just FYI!
     
unityunity