Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question App store rejected because IAP problems

Discussion in 'Editor & General Support' started by gmdisnuts, Apr 1, 2024.

  1. gmdisnuts

    gmdisnuts

    Joined:
    Aug 11, 2022
    Posts:
    3
    My game is working fine on Google Play with in app purchases. However I noticed on start up I get these two errors. I tried deleting them and reinstalling IAP. Still giving me issues.

    GUID [b4326c66a9f464640b9457cbd6237bf6] for asset 'Packages/com.unity.purchasing/Plugins/UnityPurchasing/iOS/PrivacyInfo.xcprivacy.meta' conflicts with:
    'Packages/com.unity.purchasing/Plugins/UnityPurchasing/unitypurchasing.bundle/Contents/Resources/PrivacyInfo.xcprivacy.meta'
    We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.

    and

    GUID [b4326c66a9f464640b9457cbd6237bf6] for asset 'Packages/com.unity.purchasing/Plugins/UnityPurchasing/unitypurchasing.bundle/Contents/Resources/PrivacyInfo.xcprivacy.meta' conflicts with:
    'Packages/com.unity.purchasing/Plugins/UnityPurchasing/iOS/PrivacyInfo.xcprivacy.meta'
    We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.
     
  2. madsblueray

    madsblueray

    Joined:
    Oct 2, 2022
    Posts:
    2
  3. Ricardo_Lima_08

    Ricardo_Lima_08

    Joined:
    Sep 6, 2023
    Posts:
    1
    Any updates on this? I'm having the same problem.
     
  4. madsblueray

    madsblueray

    Joined:
    Oct 2, 2022
    Posts:
    2
    What worked for me was updating Unity to the next version. I was on 2018, then I upgraded to 2019. Don't waste your time trying to edit tucked away files or find a workaround.
     
  5. unity_yB9JttLXXUNZ7A

    unity_yB9JttLXXUNZ7A

    Joined:
    Aug 11, 2021
    Posts:
    1
    The same problem is occurring even with 2020.3. I cannot change versions due to constraints, so I am waiting for an update.