Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

App in debug mode error, keystore set, still issue

Discussion in 'Android' started by JDMulti, Feb 1, 2016.

  1. JDMulti

    JDMulti

    Joined:
    Jan 4, 2012
    Posts:
    382
    I'm a Unity developer but today I was going to publish my first app to the Google Playstore. My app runs fine on the testing device, I have set the keystore and not checked 'developement' withing the publish settings.

    However, every time I try to publish it and upload the app to the playstore, I get the error: 'App is in debug mode'.
    I've searched hours to find this issue, updated my JDK, Android SDK and such, but nothing changes.
    I'm using Unity3D 5.3.0f4.

    Does anyone has an idea what I'm doing wrong? The keystore is set, I'm 100% sure and I also wrote down the correct password for it. But I'm clueless or maybe I forget something.
     
  2. JDMulti

    JDMulti

    Joined:
    Jan 4, 2012
    Posts:
    382
    I went trough these sources to find the issue:

    Official Unity reply
    http://forum.unity3d.com/threads/android-signing.62137/

    Youtube video: how to keystore


    And still have the issue that Google Playstore tells me the app is signed in Debug Mode.
    Publish settings has a checkbox for development build, but that one is also unchecked.
    Manifest file also doesn't have any values to set the app to debug mode.
    What else do I need to check to make it sign in 'Release mode'? Is this a bug?
     
  3. JDMulti

    JDMulti

    Joined:
    Jan 4, 2012
    Posts:
    382
    Found the issue.
    As the window to fill in certain information for the keystore has not specified what to fill in at the line of 'Company Code (XX)', this was creating an issue.
    The video I checked yesterday told me to fill in the country code, as a code for example a keylock is made out of numbers, I filled my country code in numbers instead of letters.
    Today I linked the above video telling me to fill in a country code..... but letters. This was creating the issue that my app was not signed for 'release', while nothing in the Unity Console told me that something was wrong.

    I would like to have Unity specify the 'Country Code' more specific, by adding what to fill in. In this case 'Country code containing 2 letters' or something.

    I wasn't able to find anywhere on the internet that this was the issue or anything else what to exactly fill in, as another video showing how to do the keystore signing actually singed it with a country code containing numbers. This is very confusing and not logical in terms of 'user experience'. Took me 1.5 day to find this issue while no documentation told me exactly what I was doing wrong.