Search Unity

App Build is 0 for all build made with UCB

Discussion in 'Unity Cloud Diagnostics' started by spacepluk, Oct 9, 2019.

  1. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    179
    As the title says. I don't have any pre/post build hooks set up in my project. And at least the android builds are getting the correct bundleVersion and the build numbers appear when I upload to Google Play. But for some reason the build number is not reflected in Unity Cloud Diagnostics' data.

    Any idea?
     
  2. ryanc-unity

    ryanc-unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,209
    Hi @spacepluk, that is very bizarre. The build number should be appearing in your reports. Are they not appearing in both crash and exception reports? We're opening a bug on this and will investigate further.
     
  3. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    179
    Hey Ryan, thanks for taking a look at this. This is the first time I'm using this so there's a big chance I'm doing something wrong.

    This is what I'm seeing in "Develop > Cloud Diagnostics > Crashes & Exceptions" when I try to filter by "App Build":

    upload_2019-10-11_18-39-46.png
     
  4. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    179
    Let me know if you need the UPID or anything else.
     
    ryanc-unity likes this.
  5. ryanc-unity

    ryanc-unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,209
    Thanks for the offer, but we were able to reproduce this bug on our end with Android builds. We're going to look into this bug right away. We will let you know when we're able to get a fix out. Thank you for bringing this to our attention.

    Could you tell us which version of Unity you're using to generate your builds?
     
    Last edited: Oct 15, 2019 at 10:50 PM
  6. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    179
    Excellent! Thanks! :)

    I'm using 2019.2.2f1 from Unity Cloud Build

    upload_2019-10-16_12-17-13.png
    upload_2019-10-16_12-17-42.png

    I'm not sure if it matters but I'm also using this workaround.