Search Unity

"API update required" pop up every time I open Unity Editor!

Discussion in 'Editor & General Support' started by BoatBest, Aug 7, 2019.

  1. BoatBest

    BoatBest

    Joined:
    Jan 4, 2016
    Posts:
    91
    First time that I open my project from 2019.1 to 2019.2 there is some error
    Here the error messages

    https://imgur.com/nXu6Jgn

    Then right now every time I open my project it said need to "API update required"
    ***This project contains scripts and/or assemblies that use obsolete APIs.
    If you choose 'Go Ahead', Unity will automatically upgrade any scripts/assemblies in the Assets folder found using the old APIs. You should make a backup before proceeding.
    (You can always run the API Updater manually via the 'Assets/Run API Updater' menu command.)***

    and I choose "I made a back up. Go Ahead!" and then there is an error message as in the picture

    https://imgur.com/h7VETA6

    I'm so confuse right now.

    Much much appreciate.
     
  2. TheDahaka

    TheDahaka

    Joined:
    Nov 11, 2016
    Posts:
    5
    Have you found a solution for this? I've been having that for several months now. Every time I open the project I need to waste time waiting for the api update :(

    Although I don't get those errors, just a log saying "Finished updating scripts / assemblies".

    Is there any way to tell what Unity thinks is out of date? Clearly some file must be corrupt or something...
     
  3. BoatBest

    BoatBest

    Joined:
    Jan 4, 2016
    Posts:
    91
    Hi @TheDahaka , Yes I forgot to update here that I was simply clicked "No" and after Unity is opened, I run an updater under Assets -> Run API Updater by myself (I wasn't sure that the button available or not after click no, but if available you should click to update it). This was get rid of the prompt, but I wasn't sure how is that. Hope this help!
     
unityunity