Search Unity

Anyone else getting poor performance with VR (openVR)?

Discussion in 'High Definition Render Pipeline' started by Warrior1424, Mar 26, 2020.

  1. Warrior1424

    Warrior1424

    Joined:
    Sep 30, 2010
    Posts:
    983
    Specs: Unity 2019.3.5f1, HDRP 7.1.8 singlepass instanced, GTX 980, OpenVR with Valve Index

    In a very basic test scene I cannot get above about 55 FPS with no post processing, volumetrics, or MSAA, regardless if build or editor. Recently just played Half-Life: Alyx at a buttery smooth framerate so surely my setup is enough to get this test scene at least close to target framerate.

    When enabling basic post processing (color grading, tonemapping, bloom) I lose about 20 fps and any MSAA brings it down to the single digits (which is interesting because I remember previously having 4x MSAA on and the framerate hanging around 35).

    My framerate is poor in VR across versions of 2019 (.1, .2, .3) even outside of HDRP but for different and weirder reasons. Updating HDRP to 7.3.1 breaks MSAA and iirc did not improve performance anyways. I know OpenVR is deprecated as of Unity 2019.3 and beyond but like I said performance is unreasonably terrible even in 2019.2. Also apparently even though it is deprecated support will still be provided for "critical fixes"?


    I'm not really sure what else to try to make this run better as I've been working with trying to get a good VR setup again for days now and my brain is pretty fried and I'm not sure at what point it would be reasonable for me to submit a bug report. Maybe (and hopefully) there's something obvious that I've overlooked.

    Here's the test scene and some profiler snapshots:


     
  2. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    A few things to look at :
    • are you running in a standalone player build ?
    • what's your rendering resolution ?
    • can you check your resolution scale in SteamVR ? (default is 150%)
    • you should disable Subsurface Scattering and others effects not required
     
  3. Warrior1424

    Warrior1424

    Joined:
    Sep 30, 2010
    Posts:
    983
    That was running in the editor so I did more tests in the standalone build below but the results are not much different. I disabled subsurface scattering but mostly everything was already disabled. My resolution scale was set to 100% and my rendering resolution was set to 100% (2016x2240) but even at SteamVR's recommended resolution of 66% (1636x1820) I could not stay above 60 fps in this test scene.

    At first I had graphics jobs enabled so I could only profile the CPU, here are the results from that:


    I went and made another build with it disabled so I could profile the GPU:


    Here are the results of the lower resolution (66% of the original):
     
  4. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    I'd say this is unexpected with this configurations. Could you log a ticket so that we can investigate ?
     
  5. Warrior1424

    Warrior1424

    Joined:
    Sep 30, 2010
    Posts:
    983
    Submitted a ticket just now, thanks! (Case 1231292)
     
  6. Meheraj7

    Meheraj7

    Joined:
    Nov 5, 2015
    Posts:
    49
    Just realized my problem thread is the same as yours, except I am having the problem for a pc game(no vr).

     
unityunity