Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Bug Annimation looping before it finishes.

Discussion in 'Animation' started by travey011, May 16, 2024.

  1. travey011

    travey011

    Joined:
    Nov 21, 2019
    Posts:
    1
    so i am new to unity, and ive searched and ive searched but can not find the answer to my problem here. i have a run animation. i got it from mixamo along with the model it is assigned to. now, when i run it is very choppy, and it is the same with all my animations except for my idle. all my animations have a transition, BACK to the idle.

    so what happens basically is the animation starts off with taking one step, and half way through the next (the other foot) it loops the animation and im stuck with this choppy mess... any advice would be appreciated.

    video of the animation: https://gyazo.com/9c1932ef73f77d4946a7040eca363502

    animation tree:
    1. https://gyazo.com/a6a0fea4148f527ea22e5f1a6a4db0e3
    2. https://gyazo.com/77c3ea40af1618239fc1a192abb23dce

    THANK YOU!
     
  2. gshape

    gshape

    Joined:
    Aug 8, 2012
    Posts:
    122
    your tree only have run-> idle, how did you make it play the “run” in the first place?
    also, because it has the run->idle, and it seems no parameter controlling to prevent it from going back to idle. of course if it ever play the run, it will go back to idle afterwards