Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Animator controller only playing entry animation

Discussion in 'Animation' started by DeclanMerry, Jun 25, 2020.

  1. DeclanMerry

    DeclanMerry

    Joined:
    Oct 14, 2018
    Posts:
    2
    Encountering a weird bug with an animation conroller:
    I created a copy of a working animator controller from a prototype character to use on an imported model with a generic rig - all animations made in blender, code and controller previously tested and working for all transitions, so only the actualy animations needed changing, right?
    When I run the game, any animation i have set to the entry state is the only one that plays, all the transitions work okay, the state that shows as playing updates as it should but the actual animation that plays is whatever animation is linked to the entry state. When I'm not in play mode, all transitions show that they move from animation to animation correctly, all the animations play okay, but in play mode it only plays whatever animation is in that first entry state. Any ideas?
     
  2. fdb_look_soft

    fdb_look_soft

    Joined:
    Dec 13, 2015
    Posts:
    8
    I have the same problem. Still fighting with it. I also ctrl+D to duplicate a controller... i tried : remove library to reload all, twice. same result.
     
  3. igmac

    igmac

    Joined:
    Aug 2, 2015
    Posts:
    5
    Same issue still exists in 2020.3.37f1 LTS exactly as described. Did you either of you ever get a solution or workaround?
     
unityunity