Search Unity

Animating rotation not working on android build... ?

Discussion in 'Animation' started by ramioooz, Dec 19, 2015.

  1. ramioooz

    ramioooz

    Joined:
    Feb 15, 2015
    Posts:
    28
    Hello Developers.

    I am using latest unity for now version 5.3.

    Using Animator to animate rotation values of an object is not working in mobile builds. animating rotation works fine on PC - but as soon as I try to test on android - object disappears as soon at it start rotating.

    Doing rotation through C# coding works find - but I want to do it through "Animator".

    Thanks in advance. have a happy new year ;)
     
  2. ramioooz

    ramioooz

    Joined:
    Feb 15, 2015
    Posts:
    28
    I just installed the latest version up to now (5.3.1) - problem remains.
    still no rotation animation on android :(
     
  3. Piilorasva

    Piilorasva

    Joined:
    Dec 20, 2015
    Posts:
    1
    Hey ramiooz, I have the exact same problem with my build :( Was pain to debug what caused it, had to build whole scene again piece by piece and make a new build very often.
     
  4. jbjbjbborisb

    jbjbjbborisb

    Joined:
    Jun 8, 2014
    Posts:
    54
    Same problem here :-(
     
  5. danieltdf

    danieltdf

    Joined:
    Oct 2, 2015
    Posts:
    2
    Exactly the same problem here..since 5.3
     
  6. jamius19

    jamius19

    Joined:
    Mar 30, 2015
    Posts:
    96
    same problem here too!
    getting irritated by all these bugs! :mad:

    why add more features when we can't just use the old ones perfectly without any bug!
     
  7. danieltdf

    danieltdf

    Joined:
    Oct 2, 2015
    Posts:
    2
    Sadly I had to downgrade to Unity 5.2 due to this problems...so far I´ve found three (colliders with scaling objects, particle systems and this animated rotation related one) :(
     
  8. Dickie

    Dickie

    Joined:
    Jan 10, 2014
    Posts:
    6
    pretty sure I'm having the same issue :(
     
  9. manthoR

    manthoR

    Joined:
    Apr 21, 2014
    Posts:
    25
    Post the workaround here also :

    Thanks to this bug report (and unity feedbacks) I test the workaround and it works for me :
    Just right click on every rotation entries on your animations to change the interpolation mode to "Quaternion" or "Euler angles (Quaternion approximations)"

    Oh and... Happy new year :)
     
  10. jamius19

    jamius19

    Joined:
    Mar 30, 2015
    Posts:
    96
    Will try on Android tonight ;)
    Oh happy new year too :D
     
  11. fishg

    fishg

    Joined:
    Jul 25, 2014
    Posts:
    90
    Thanks.But not work by this change to iOS.
     
  12. jbjbjbborisb

    jbjbjbborisb

    Joined:
    Jun 8, 2014
    Posts:
    54
    Why is there no official comment on this? Would be great to know if someone is working on this.
    The latest patch update for 5.3 does not seem to include a fix either...
     
  13. Almakos

    Almakos

    Joined:
    Dec 13, 2013
    Posts:
    179
    Hey guys,
    so I've figured out that if you are using "optimise game objects" checkbox for your RIGs in Unity 5.3
    then transforms go nuts and nothing works as expected on the device (iOS in my case)
     
  14. jbjbjbborisb

    jbjbjbborisb

    Joined:
    Jun 8, 2014
    Posts:
    54
    That does not work for me (Android) :-(
     
  15. Zamaroht

    Zamaroht

    Joined:
    Nov 4, 2013
    Posts:
    18
    This definitely worked, thank you!
     
  16. immeasurability

    immeasurability

    Joined:
    Apr 22, 2014
    Posts:
    106
    5.3.1p4 same problem here too!
    change all keys to Quaternion not fast, the bad( but works
     
  17. ChrisLoh

    ChrisLoh

    Joined:
    Jul 30, 2014
    Posts:
    2
    manthoR, you're a legend. It definitely resolves the problem. Well done. I've been ripping my hair out and been disheartened for days. I had just submitted a bug report and demo scene to Unity with this issue. Thank you.
     
    manthoR likes this.
  18. joostbos

    joostbos

    Joined:
    Feb 4, 2015
    Posts:
    41
    Thanks for the workaround. That did the trick :)
     
  19. bart_bender

    bart_bender

    Joined:
    Mar 21, 2015
    Posts:
    20
    Thanks for the workarround, It was driving me mad
     
  20. Gotama

    Gotama

    Joined:
    Feb 16, 2014
    Posts:
    4
    Thank you for sharing the workaround! You saved me(us ) :)
     
  21. yuranu

    yuranu

    Joined:
    Jan 3, 2015
    Posts:
    1
    Hey, thanks. I thought I was going crazy. Thanks for the workaround. The problem still exists in build 5.3.2f1.
     
  22. tsangwailam

    tsangwailam

    Joined:
    Jul 30, 2013
    Posts:
    280
    Thanks for the workaround. But changing all key is lots of work. :(
     
  23. jdscogin

    jdscogin

    Joined:
    Oct 26, 2014
    Posts:
    69
    Thanks, I was really scratching my head on this. Other animations worked, but they had no rotation. This solved the problem
     
  24. rmgomez

    rmgomez

    Joined:
    Oct 2, 2014
    Posts:
    10
    You dont need to change every key, just select the rotation property and do as described above.

    Thanks for the workarround
     
unityunity