Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Bug Android SDK not found

Discussion in 'Editor & General Support' started by Piflik, Sep 9, 2020.

  1. Piflik


    Sep 11, 2011
    I recently upgraded to Unity 2020.1.4f1, and although I installed the Andoide SDK, et al, Unity throws an exception when I try to build for Android.

    DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files\Unity\Hub\Editor\2020.1.4f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\build-tools'.

    The path exists and (as far as I can tell) contains a valid Android SDK.

    I tried providing the paths manually, in Preferences, and now I additionally get a warning in the preferences window, stating that the Version of the SDK is not supported.
    I also tried chaning the path to a previous SDK installation (Unity 2019.4.9f1). I get the same warning about the SDK Version, but no DirectoryNotFoundException. Instead the gradle build fails.

    Attached Files: