Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

[android] running slow on lowest quality setting.

Discussion in 'Editor & General Support' started by OmarVector, May 5, 2018.

  1. OmarVector

    OmarVector

    Joined:
    Apr 18, 2018
    Posts:
    40
    I made a very simple scene with 4 planes, some random low poly rocks.

    On quailty setting, I made it lowest, no PPV, no AA, no Vsyn, nothing at all but lowest, it run 25-30fps on my device.

    which is impossible. even forcing Application.SetTragetFrameRate = 60, with no hope.
    On other side, the same map design working 60fps from other engine.
    Using profiler, indicate nothing than rendering take like 35-65%
    same performance on release build.

    I'm using unity personal, is that a kind of restriction?

    My device : Hawuii G8 , it has quite good hardware spec.

    I can send the project to any technical person from unity to discuss that.

    Edit:
    Using standard shaders or even the new lightweight render pipeline shaders, results are the same
     
  2. Immortalis94

    Immortalis94

    Joined:
    Feb 22, 2017
    Posts:
    11
    @OmarVector This is maybe old post but setting v-sync to every v-blank fixes the problem with FPS on mobile.
     
  3. OmarVector

    OmarVector

    Joined:
    Apr 18, 2018
    Posts:
    40
    that didnt work for me

    I created a bug report just like that

    Simple scene run too slow on Adrino405 gpu

    1. What happened
    On Hawuii G8 which has Adrino405 Gpu, simple scene is running too slow 27fps on lowest quailty settings.

    2. How we can reproduce it using the example you attached
    (1) Create simple scene that has 1 plan, 10 cubes , apply simple standard material to them.
    (2) Check Quality setting to be lowest.
    (3) Disbable casting shadow to all objects in the scene and motion vector.
    (4) Disable HDR . and make sure its forward rendering .
    (5) I added simple FPS script and camera transform script using Sin().
    (6) I was too sure that Vsync is disabled.


    Android Version : 6
    Device: Huawei G8
    Unity Version Tested : 2017 to 2018.2 , however in some versions FPS could hit 35-45 which still too low for simple scene.

    My Comment:
    I played SkyForce game, and it has stunning visual look and run too smooth on my device with all that detail like 45fps , how it could be 27fps on simplest scene .

    MyWork Around :
    -I tried the new scriptable pipeline , no much different.
    -Worked with profiler and found that Gfx.waitForPresent consume upt to 90% .
     
  4. OmarVector

    OmarVector

    Joined:
    Apr 18, 2018
    Posts:
    40
    its strange that one of the Unity Team comments on this thread and he deleted all his comments , why that happened?!!
     
  5. OmarVector

    OmarVector

    Joined:
    Apr 18, 2018
    Posts:
    40
    Update: Today I received an email from unity that they were able to reproduce this bug and sent it to their developers to resolve it.

    So yes, its a bug
     
unityunity