Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Question Android graphics go crazy when switching from Vulkan to OpenGLES3

Discussion in 'Unity MARS' started by SpillYerLungs, Nov 24, 2021.

  1. SpillYerLungs


    May 13, 2020

    I've got a basic MARS-powered project up and running just fine on my iOS device. The main camera rotates around a 3D scene, and the MARS camera does some basic face landmark tracking.

    The problems began when I tried building for an Android device (Galaxy Tab S3). I know supporting ARCore requires removing Vulkan from the Graphics APIs list; I did so, leaving OpenGLES3. When I run on my device, the graphics look fine for a fraction of a second, then become this weird mess – all light sources are disabled, and some opaque objects become sort of transparent.

    I've done plenty of googling to no avail. Any help at all would be appreciated!

    (Disclaimer: Have only been using Unity for a few months. Have only been using MARS for a few days. Have never developed for Android before.)

    Screenshot_20211123-162230_Simple v5.jpg
  2. CiaranWills


    Unity Technologies

    Apr 24, 2020
    Do you have any other Android devices you can try?

    If you're happy to share your project then you can file a bug report from the Help > Report a bug... menu and we can take a look.