Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

Android: can't set minimum API level

Discussion in 'Android' started by elv1s42, Mar 3, 2019.

  1. elv1s42

    elv1s42

    Joined:
    Feb 18, 2019
    Posts:
    1
    Hi All

    For some reason I can't set API levels inside Unity settings (both Minimum and Taget):
    upload_2019-3-3_16-25-14.png
    (Build setting -> Player settings... -> Other settings)

    No onptions are available when clicking on both dropdown items.

    I am using Unity 2019:
    upload_2019-3-3_16-29-2.png

    Also I've tried to use custom location for Android SDK (installed with Andoid Studio):
    upload_2019-3-3_16-23-58.png

    upload_2019-3-3_16-31-27.png

    Can someone please help me to resolve the issue?

    Thanks everyone
     
    cxgrebe and musickgm like this.
  2. JuliusM

    JuliusM

    Unity Technologies

    Joined:
    Apr 17, 2013
    Posts:
    394
    Do you get any errors in editor console? Also in the Android Studio screenshot you've shown only the SDK Platforms tab. Take a look at the SDK Tools tab and make sure you have tools, build tools and platform tools installed as well.
     
  3. Ghosthowl

    Ghosthowl

    Joined:
    Feb 2, 2014
    Posts:
    178
    I have the same issue. It is caused for me by using Linear Color Space as opposed to Gamma. I attempted to resolve it by updating to 2019.2.0a7 but was met with a different issue in a thread I created here.
     
  4. musickgm

    musickgm

    Joined:
    Mar 19, 2016
    Posts:
    15
    This is still a problem for me. Any updates on this?
     
  5. rohitdesai

    rohitdesai

    Joined:
    Jul 26, 2019
    Posts:
    4
    Same here Unity 2019.3.0a12 also tried with 2019 beta version.
     
  6. sv955

    sv955

    Joined:
    Dec 24, 2017
    Posts:
    8
    I am also facing same issue in Unity 2019.2.0f1 (64-bit). Minimum API Level List it getting populated in Unity 2018.3.0f2 (64-bit) but not in Unity 2019.2.0f1 (64-bit)
     
  7. hrmt

    hrmt

    Joined:
    Jan 1, 2016
    Posts:
    1
    me too! :)
    2019.2.3f1

    but I got a solution:
    1. you can edit file in: <your-project>/ProjectSettings/ProjectSettings.asset
    2. there's a property named `AndroidMinSdkVersion` change the value to any minimum API level you want.
    there are other settings that you can change too.
     
    Last edited: Sep 3, 2019
    unity_53laEKgoVKGBOg likes this.
  8. asgarcia

    asgarcia

    Joined:
    Jan 25, 2019
    Posts:
    4
    Hey hrmt,
    Having the same issue and opened the ProjectSettings.asset file and the AndroidSDKVersion was already set to 19, but it still is blank in the Player settings? Should I change it to something different? The AndroidTargetVersion was at 0, not sure if changing that would help?
     
  9. asgarcia

    asgarcia

    Joined:
    Jan 25, 2019
    Posts:
    4
    I am using 2019.2.3. Maybe it is a firewall issue, it works fine on my home network. Everything else works through the company network, except the minimum api level in the player settings.
     
  10. Nashiru

    Nashiru

    Joined:
    Mar 5, 2018
    Posts:
    2
    Connect your editor with Internet service then it will appear
     
  11. Nashiru

    Nashiru

    Joined:
    Mar 5, 2018
    Posts:
    2
    Connect your device with Internet service then it will appear
     
    ozzgirlrpg likes this.
  12. rohitdesai

    rohitdesai

    Joined:
    Jul 26, 2019
    Posts:
    4
    it might also be a admin issue try installing unity in main drive which has admin access.
     
  13. wenzhao

    wenzhao

    Joined:
    Oct 28, 2013
    Posts:
    6
    Same Issue!!!!!
    Unity2019.2.8f1
    It's driving me crazy!
     
  14. dominykasm

    dominykasm

    Unity Technologies

    Joined:
    May 27, 2018
    Posts:
    51
    Are you getting any errors in the console?
     
  15. wenzhao

    wenzhao

    Joined:
    Oct 28, 2013
    Posts:
    6
    No, no errors were printed
     
  16. dgonzalezt

    dgonzalezt

    Joined:
    Feb 14, 2017
    Posts:
    1
  17. H-Rat

    H-Rat

    Joined:
    Apr 8, 2015
    Posts:
    2
    i just turned on a vpn and then its worked
     
  18. washableway

    washableway

    Joined:
    Nov 18, 2019
    Posts:
    1
    Any updates on this?
     
  19. anand-a

    anand-a

    Joined:
    Jul 23, 2013
    Posts:
    1
    same issue @ unity 2019.2.1.f1 - mac 10.14.5 Screenshot 2019-11-19 at 12.28.07 PM.png
     
  20. rohitdesai

    rohitdesai

    Joined:
    Jul 26, 2019
    Posts:
    4
    i tried to close and reopen sometimes works.
    also configure a proxy for android sdkmanger
    with following command on terminal and launch the unity.
    ./sdkmanager --proxy=http --proxy_host= yourproxyurl --proxy_port=8080 --list