Search Unity

Question Android build failed with 3 errors.

Discussion in 'Editor & General Support' started by farkenar, Feb 13, 2024.

  1. farkenar

    farkenar

    Joined:
    Jan 15, 2022
    Posts:
    1
    Hey, i've been working on my project for university for about a month now, and when it is finally done, i've come across some errors i have no idea how to resolve.

    Those are the errors:

    WARNING:We recommend using a newer Android Gradle plugin to use compileSdk = 33

    This Android Gradle plugin (7.1.2) was tested up to compileSdk = 32


    Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF-8

    FAILURE: Build failed with an exception.


    CommandInvokationFailure: Gradle build failed. 
    B:\Unity\unity editor\2022.3.19f1\Editor\Data\PlaybackEngines\AndroidPlayer\OpenJDK\bin\java.exe -classpath "B:\Unity\unity editor\2022.3.19f1\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\gradle\lib\gradle-launcher-7.2.jar" org.gradle.launcher.GradleMain "-Dorg.gradle.jvmargs=-Xmx4096m" "assembleDebug"


    Firstly, I thought that maybe my projects is raising those issues, but as it turns out, even blank "mobile" project has the same problem.

    Ah, and i would like to note that firstly i got some errors with adaptive performance which i resolved by enabling Frame Timing Stats in Project Settings (which I should have done while setting my project up, tbh).

    Below some screenshot of my configuration:

    upload_2024-2-13_22-27-35.png
    upload_2024-2-13_22-28-53.png

    I hope that someone can help me with this issue.
     
    ekinzu likes this.