Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Android API level 29

Discussion in 'Android' started by KreizLand, Jul 22, 2020.

  1. KreizLand

    KreizLand

    Joined:
    Jul 12, 2017
    Posts:
    43
    Google requiremet is API level 29 scince August, but I only have 28 on Unity 2019.4.1f, kinda strange
    External tools:
    upload_2020-7-22_23-46-11.png
    In player settings:
    upload_2020-7-22_23-34-48.png
    If I pick 29 API level:
    upload_2020-7-22_23-48-41.png
     

    Attached Files:

    brucejs777 likes this.
  2. victorw

    victorw

    Unity Technologies

    Joined:
    Sep 14, 2016
    Posts:
    377
    Try looking in the Android forums for that problem. As you noted, API level 29 appears in the dropdown and should be supported by 2019.4.1f1.
     
  3. Sailendu

    Sailendu

    Joined:
    Jul 23, 2009
    Posts:
    183
    API level 29 worked for me, I just tried building with Unity 2019.4.3f1, I selected "API Level 29" from the "Target API Level" dropdown in player settings. Then when I started the build, it asked me to upgrade the installed API level to 29, I hit upgrade and it downloaded the API level and build succeeded, checked in the Unity Hub installed folder and the SDK for API 29 is now installed there, then uploaded to Google Play and received no warning about API level 29. I am attaching a screenshot from Google Play console for confirmation.

    Screenshot 2020-07-23 at 2.53.41 PM.png
     
  4. HectorOfPriamos

    HectorOfPriamos

    Joined:
    Jul 9, 2017
    Posts:
    10
    I tried as you did Sailendu but in my case I couldn’t upgrade it. I’m using 2020 1.0f1 but no solution
     
  5. Arman132

    Arman132

    Joined:
    Jul 1, 2020
    Posts:
    1
    I have got this problem in 2020 1.0f1 but when I want to upgrade to 29 API as Sailendu said it doesn't work.
     
  6. realgamingart

    realgamingart

    Joined:
    Apr 10, 2014
    Posts:
    20
    In my point of view the Android SDK and Unity do not have the same path. I means your new unity is using Old path and you can not find a way to find out how to this (Even you are seeing the both part are the same) ?? Here is the solution.

    First Uninstall the unity and android SDK then Install the unity from Unity Hub and allow the unity hub to download the android sdk from the scratch.
    And also do not forget to install the important Android SDK tools.

    In my case the things started to work. I hope in your case the things will start to work and you will get the API level 29.
     
  7. kishore_1234

    kishore_1234

    Joined:
    Aug 14, 2017
    Posts:
    8
    Hi iam using version 2019.4.5f1 and api 29 is showing in dropdown but when i try to set it it is asking for update and i tried to install it is showing installation failed
     
  8. CJSstudios

    CJSstudios

    Joined:
    Apr 15, 2019
    Posts:
    3
    I have similar issue.
    2019.4.5f1
    API 29 and 30 fail to update.
    Working on fix.
     
  9. CJSstudios

    CJSstudios

    Joined:
    Apr 15, 2019
    Posts:
    3
    I got a success build, still waiting to see if workable apk.
    I have Android SDK installed in its own folder using the install from Android Studio.
    I went to C:/Android/sdk folder and
    Copy the build tools and platforms into the Unity Hub folder.

    C:\Android\sdk\build-tools\29.0.2
    copy to
    C:\Program Files\Unity\Hub\Editor\2019.4.5f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\build-tools\29.0.2

    C:\Android\sdk\platforms\android-29
    copy to
    C:\Program Files\Unity\Hub\Editor\2019.4.5f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\platforms
    to give you
    C:\Program Files\Unity\Hub\Editor\2019.4.5f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\platforms\android-29

    Then select API 29 in Unity Player Settings and build, it shouldn't ask you to update your API and successfully compile.

    Not sure of the after effects yet though.
    Use with caution.
     
    MakyG_cz, felipebernal and mahdie like this.
  10. CJSstudios

    CJSstudios

    Joined:
    Apr 15, 2019
    Posts:
    3
    Upload to Google Play is successful and August API 29 deadline warning has been removed.
    APK runs as expected after compile.

     
  11. kishore_1234

    kishore_1234

    Joined:
    Aug 14, 2017
    Posts:
    8
  12. AnisimovArthur

    AnisimovArthur

    Joined:
    Mar 4, 2013
    Posts:
    15
    On MacOS Unity 2019.3.7 successfully updated API to 29.
     
  13. KreizLand

    KreizLand

    Joined:
    Jul 12, 2017
    Posts:
    43
    I had to install Android Studio to get Androind SDK Manager (could find it anywhere else) then I installed SDK level 29 via Manager and copied some folders (missing build tools and platforms) from Android Studio SDK to Unitys SDK - it works for me.
     
    PuddingEntertainment likes this.
  14. jumadiazgranados

    jumadiazgranados

    Joined:
    Jun 7, 2019
    Posts:
    4
    I ran the sdkmager.bat on a Windows console (as administrator) located in C:\Program Files\Unity\Hub\Editor\2019.4.6f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\tools\bin. The typed command was sdkmanager "platform-tools" "platforms;android-29" "build-tools;29.0.3" and API level 29 got installed. Unity built the android app normally.

    For more info about running the sdkmanager https://developer.android.com/studio/command-line/sdkmanager

    The error for update on Unity seems to be related with administrator permissions for file writing on Windows.
     
    Last edited: Aug 3, 2020 at 6:57 PM
    yesemenovagames and Flarup like this.
  15. joepeijkemans

    joepeijkemans

    Joined:
    Apr 24, 2018
    Posts:
    4
    Will this also work for Unity 2019.1.7f1? I'm experiencing this same problem rn
     
  16. jumadiazgranados

    jumadiazgranados

    Joined:
    Jun 7, 2019
    Posts:
    4
    I guess, because it is updating the android sdk independently. Search the path in your Unity version.
     
  17. bigbrainz

    bigbrainz

    Joined:
    Jul 21, 2015
    Posts:
    115
    Hmmm . . . after accepting the agreement for installing Android SDK Platform 29 in 2019.4.6f1 I get an error: "Warning: Failed to read or create install properties file."

    Ah. Had to run Command Prompt as Admin. Probably if I had Unity running as Admin it could have done it as well?
     
    Last edited: Aug 3, 2020 at 9:06 PM
  18. jumadiazgranados

    jumadiazgranados

    Joined:
    Jun 7, 2019
    Posts:
    4
    Yes command prompt should be started as Admin.

    And yes, somewhere else somebody made the suggestion of starting Unity as Administrator.
     
    Last edited: Aug 5, 2020 at 4:46 PM
  19. adamstepinski

    adamstepinski

    Joined:
    Aug 7, 2015
    Posts:
    9
    Worked when I closed Unity Hub, ran UnityHub as Administrator, opened Android project, built
     
  20. victorw

    victorw

    Unity Technologies

    Joined:
    Sep 14, 2016
    Posts:
    377
    FYI I split off this discussion from the previous one happening in Unity Cloud Build forums since this all seems to be useful discussion around local builds which deserves better visibility in a forum where it's more likely to be seen by other Android developers and the Android platform team.
     
  21. Pijush-Paldragon

    Pijush-Paldragon

    Joined:
    Aug 14, 2014
    Posts:
    4
    Worked for me, thanks
     
  22. ifthenelseofficial

    ifthenelseofficial

    Joined:
    Nov 5, 2019
    Posts:
    3
    Thank you so much, it helped me
     
  23. Flarup

    Flarup

    Joined:
    Jan 7, 2010
    Posts:
    129
    Thank you very much. Worked for me as well!
     
    jumadiazgranados likes this.
  24. bigbrainz

    bigbrainz

    Joined:
    Jul 21, 2015
    Posts:
    115
    Starting Hub as Admin doesn't work for me. Updating to 2019.4.7f1 made me go through the whole command line thing again. Argh.
     
unityunity