Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

An error occurred when import FBX Exporter with 2019.1 alpha

Discussion in '2019.1 Beta' started by Kichang-Kim, Jan 29, 2019.

  1. Kichang-Kim

    Kichang-Kim

    Joined:
    Oct 19, 2010
    Posts:
    246
    Hi, When I import FBX Exporter ( Unity's official asset : https://assetstore.unity.com/packages/essentials/fbx-exporter-101408 ), an error occurred like this:
    When/will this asset be updated for 2019.x?
    Thanks.
     
  2. Kichang-Kim

    Kichang-Kim

    Joined:
    Oct 19, 2010
    Posts:
    246
    The package manager version of FBX Exporter makes another error:
     
  3. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,609
    Sounds like it asks for Timeline there? Do you have the Timeline package disabled?

    I also had trouble making the fbx export package work (in 2018.3), something about it being unable to load the dll as well, so I uninstalled it and used the version of it that is on the asset store, which works fine.
     
  4. Kichang-Kim

    Kichang-Kim

    Joined:
    Oct 19, 2010
    Posts:
    246
    Uniyt Timeline package is imported and enabled. Re-installing each packages does not work. I think that the current version of FBX Exporter (2.0.1-preview.2) does not recognize new Unity Timeline package (separated from Unity engine at Unity 2019.x).
     
  5. Kichang-Kim

    Kichang-Kim

    Joined:
    Oct 19, 2010
    Posts:
    246
  6. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,609
    Why would an FBX Exporter depend on Timeline though is kind of a head scratcher.
     
    Kichang-Kim likes this.
  7. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    1,402
    An update to the fbx exporter with a fix for this issue should become available in the next couple of days.
     
  8. markvi

    markvi

    Unity Technologies

    Joined:
    Oct 31, 2016
    Posts:
    47
    The fix is out: #437
     
  9. Blindsighted

    Blindsighted

    Joined:
    Apr 20, 2019
    Posts:
    1
    Installed the plugin today using 2019.1.0f2 and get the same error mentioned above.
     
  10. erlGrey

    erlGrey

    Joined:
    Apr 8, 2014
    Posts:
    16
    Sorry to bump, but it's the same with 2019.1.5f1. Has anyone gotten it to work? Other parts of my project won't work in 2018, or I'd just do it there :)

    (And my Unity Timeline package is imported and active.)
     
  11. israelteich

    israelteich

    Joined:
    Mar 6, 2018
    Posts:
    1
    i hope they fix it or make it part of Unity proper. this is a very useful and somewhat necessary tool