Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Ambient sound getting quieter when other sounds playing

Discussion in 'Audio & Video' started by dragriff, Feb 17, 2016.

  1. dragriff

    dragriff

    Joined:
    Oct 22, 2015
    Posts:
    34
    Hello, so my issue is as the title states.

    I have tried adding some ambient sounds in various ways, and they all worked, but whenever I started walking with my character and its footsteps were heard, it seems like the ambient sound quiets down, even a few seconds AFTER the footstep sounds. After which it slowly fades back in.

    How could I fix that?

    Thank you.
     
  2. Hyblademin

    Hyblademin

    Joined:
    Oct 14, 2013
    Posts:
    725
    Sounds like volume ducking or compression. Do you have an active audio mixer with either of these effects?
     
  3. StellarVeil

    StellarVeil

    Joined:
    Aug 31, 2018
    Posts:
    4
    Answer in case other people run into this issue in the future:
    It may be that you have both AudioSources' Spatial Blend setting set to 2D i.e to 0 for both sounds (ambient/music & the footsteps).
    What you should do is set the ambient/music to 2D and the other sfx to 3D but let's suppose you want to have multiple ambient sounds at the same time (e.g wind and birds) and you notice one getting weaker if they're both 2D then you can put both as 3D and attach them to the camera or wherever you have your AudioListener.
     
  4. flippedBrain

    flippedBrain

    Joined:
    Aug 17, 2014
    Posts:
    53
    Thanks but this solution isn't working for me.
    Still the same issue:
    I don't use the internal audio mixer. I have one listener attached to the mainCamera and set the ambient sound to 2D and the handgun sfx to 3D. When I shoot the ambient sound lowers down (roughly 30% I'd guess) before it fades back to full volume.

    Unity 2019.2.19f1
     
    Last edited: Feb 1, 2020
  5. StellarVeil

    StellarVeil

    Joined:
    Aug 31, 2018
    Posts:
    4
    Sorry for the late reply, I tried a few things when I had the chance and the only thing I can recommend you try is lowering the min & max distance (give both the same value) in the 3D setting of the AudioSource, values like 1 or 0.6 or maybe a bit higher, you have to try until you find one that is audible enough and doesn't cause the dampening. I'm using Unity 2019.3.06f
     
  6. BrandyStarbrite

    BrandyStarbrite

    Joined:
    Aug 4, 2013
    Posts:
    1,365
    I wonder if this could be a script problem causing this problem?
     
unityunity