Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Let us know a bit about your interests, and if you'd like to become more directly involved. Take our survey!
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Allow Fullscreen Switch

Discussion in 'Documentation' started by Baste, Feb 16, 2017.

  1. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    3,347
    The manual for the standalone Player Settings is missing information about the "Allow Fullscreen Switch" option.
     
  2. Graham-Dunnett

    Graham-Dunnett

    Unity Technologies

    Joined:
    Jun 2, 2009
    Posts:
    4,288
    Yep. The 5.6 docs and the existing docs on Player Settings are differing... Thanks, as always for the observation and sharing.
     
  3. LW

    LW

    Joined:
    Jun 23, 2013
    Posts:
    6
    Where can I find the information on Allow Fullscreen Switch? It could mean a number of different things.
     
    Shinyclef likes this.
  4. Shinyclef

    Shinyclef

    Joined:
    Nov 20, 2013
    Posts:
    202
    I just came searching for a description of this setting. Still missing from the docs.
     
  5. andrar

    andrar

    Unity Technologies

    Joined:
    Sep 27, 2017
    Posts:
    6
    The setting determines whether the user is able toggle the fullscreen mode using Alt+Enter on Windows and Command+F on Mac.
     
    atomicjoe likes this.
  6. TigerBooks

    TigerBooks

    Joined:
    Jul 31, 2015
    Posts:
    9
    This works, which is great, but I can still go into fullscreen on mac via the buttons in the top left of the window. How can I disable these?
     
  7. andrar

    andrar

    Unity Technologies

    Joined:
    Sep 27, 2017
    Posts:
    6
    This is a known bug in Unity. Try turning off the resizable window in player settings.