Search Unity

All scene Visual Effects updated on scene view

Discussion in 'Visual Effect Graph' started by pepe_q, Sep 7, 2021.

  1. pepe_q

    pepe_q

    Joined:
    Dec 1, 2016
    Posts:
    4
    (using Unity 2019.4.28f1) Hi, I have currently a performance problem on editor scene view (game is stopped) that is so heavy it makes very difficult to handle the scene (~7fps). After a performance investigation I found that the large amount of Visual Effect components I have on my scenes are being updated and drawn on scene view thus forcing the scene view repaint every frame regardless the contained objects are selected, plus I cannot find any way to disable them, via Gizmos toolbar for instance.

    I seem to recall the old Unity particle systems only plays previews when selected, is there any way to get the same behavior or to disable any preview on editor code? Thank you.

    upload_2021-9-7_17-44-13.png
     
  2. pepe_q

    pepe_q

    Joined:
    Dec 1, 2016
    Posts:
    4
    I checked myself that while game is stopped I can disable emission with VisualEffect's pause = true but when I press play to start the game none of Awake, Start, OnEnable functions inside VisualEffect component seems to be initializing pause, is that intended?
    Also, it feels weird that pause state gets set again after stopping the game, that sounds like the opposite it should be doing? Is there anything I'm missing about emission start policy that is so different from the old ParticleSystem?
    Thanks
    -Pepe
     
unityunity