Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

All pink!

Discussion in 'Windows' started by Deleted User, Jan 26, 2016.

  1. Deleted User

    Deleted User

    Guest

    I know about this issue before, but as you see all my textures and materials with their shaders work in Unity itself.
    My app looks good when running in Unity, and no errors in the Console:


    MC2ingame.jpg

    But when I test it after build succeeded in VS 2015 I get this!

    MC2pink.jpg

    How can I fix this? I dont even know where to start!
    Hope someone can help, thanks!
     
    Last edited by a moderator: Jan 26, 2016
  2. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    3,819
    Which Unity version is this ? Which Windows Store SDK ? Please check and attach UnityPlayer.log to this thread.
     
  3. GarthSmith

    GarthSmith

    Joined:
    Apr 26, 2012
    Posts:
    1,240
    My first guess would be a shader issue. Do you have any camera shaders that take up the whole screen?
     
  4. Deleted User

    Deleted User

    Guest

    Thanks for replies -

    @Tomas 1856 - Unity 5.2.1p4, Windows 10 SDK 10.0.0, VisualStudio 2015 14.0.23107.0 D14REL

    Im sorry for my ignorance but I cant find UnityPlayer.log in this Unity on Windows - on Mac I find it in the Console Editor but here I have no choices when I open Console-Editor?
    I tested this project with the Test file in the Build folder after successful build in VisualStudio.

    @ Garth Smith - yes, thats my guess to, but since I dont have any missing textures or shaders within Unity and no shader attached to the camera I cant figure out where to look. The camera is a simple first person camera, attached to the first person controller and with forward rendering.
     
  5. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    10,628
    You could try using VS graphics debugger to see how the frame is drawn and which step messes it up.
     
  6. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    3,819
    The log file is located here user>\AppData\Local\Packages\<productname>\TempState
     
  7. Deleted User

    Deleted User

    Guest

    Thanks for your replies! I have looked at the log but cant find aything I understand. Yet. I feel I have to learn VS a LOT better. Thing is that this is a project that runs find on Mac and iOS, and its on the AppStore.
    I switched the build Settings on Mac to standalone build and then exported it to my Windows machine. But I set it to build for Mac, so maybe I would try to build for Windows? At the time it felt weird to do that on a Mac, but I'm not sure how to do it?
    I am used to work on Mac with Xcode.
     
  8. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    10,628
    Can you show us the log file?

    You could use visual studio graphics debugger to inspect which draw call makes it go pink. In VS, press Debug -> graphics -> start diagnostics, then capture a pink frame once it appears and finally inspect various stages of the frame.
     
  9. Deleted User

    Deleted User

    Guest

    Thanks, Ill try that and come back!
     
  10. Deleted User

    Deleted User

    Guest

    That was an interesting experience! I found a couple of shaders that was labeled 'ínternal shader error' and as 'hidden'. I thought I had gone through all shaders and changed them to mobile but when I searched for 'hidden shaders' I found some more! So I started once again to change all shaders to mobile. But then I got new errors with those! Like 'shader error buffer start' and 'shader error mobile/particle/additive' and such. So I did something wrong, because those shaders cant be faulty, I said to myself.
    So I decided to skip that project and start from scratch.
    Same shader error in a blank new project with nothing in it! This time the error was in skybox...
    Geez, best to update Unity then I thought. My last attempt...
    And voila! Tested with the old project, ran Debug - graphics, no errors! Ran the test-file, no errors! Now I'm uploading it to windows store/fingers crossed!!

    Thanks again for taking time and help out :)