Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

All animations (or rigging) broken after upgrade to Unity 2019.2

Discussion in 'Animation' started by Phalcon, Jan 4, 2020.

  1. Phalcon

    Phalcon

    Joined:
    Feb 16, 2017
    Posts:
    6
    Hi,

    I recently upgraded my project(s) to Unity 2019.2, and everything is working fine apart from my animations. All my rigged meshes seems to be completely broken in Unity. This is what I see in the scene view of my prefab,

    upload_2020-1-4_15-56-23.png

    Whereas this is how the mesh looks in Blender:

    upload_2020-1-4_15-57-1.png

    I've had 0 issues with this prior to the update, and have already tried reimporting assets, and disabling GPU Skinning. I'm currently out of ideas. Does anyone know what may be causing this?

    Thanks in advance!
     

    Attached Files:

  2. sand_lantern

    sand_lantern

    Joined:
    Sep 15, 2017
    Posts:
    211
    I just had a similar issue when upgrading from 2019.2.7 to 2019.2.17. I'd suggest trying to install a few older versions in the 2019.2 version history and see if it gets you anywhere. I'm going to try to figure out exactly where it broke for me tomorrow. Hard to say if we're having the same issue or not though.
     
  3. tl1024768

    tl1024768

    Joined:
    Feb 27, 2020
    Posts:
    6
    bump this, I adjust Skin Weights in Project Settings->Quality to 4 Bones and fixed a similar issue. hope it will help.