Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Agents don't walk on walkable surface

Discussion in 'Navigation' started by Xhitman, Jun 7, 2019.

  1. Xhitman

    Xhitman

    Joined:
    Oct 30, 2015
    Posts:
    436
  2. Yandalf

    Yandalf

    Joined:
    Feb 11, 2014
    Posts:
    434
    Looks like they're not using NavmeshOffLinks, make sure autoTraverseOffMeshLinks is turned on for your agents.
     
  3. Xhitman

    Xhitman

    Joined:
    Oct 30, 2015
    Posts:
    436
    AutoTraverseOffMeshLinks is on, but agents still avoid the top surface.
     
  4. Yandalf

    Yandalf

    Joined:
    Feb 11, 2014
    Posts:
    434
    We're gonna need a bit more info to help you further then.
    How are you dealing with this? What are your settings etc?
     
  5. Xhitman

    Xhitman

    Joined:
    Oct 30, 2015
    Posts:
    436
    agent radius: 8
    agent height 20
    max slope 30
    step height 5

    drop height 50
    jump distance 50

    The walkable surface(I change the box to a plane) y position is 10
     
unityunity