Search Unity

Advertisements.dll not loading due to UnityEditor.iOS.Extensions.Xcode being incompatible?

Discussion in 'Editor & General Support' started by ao02, Sep 11, 2019.

  1. ao02

    ao02

    Joined:
    Nov 11, 2018
    Posts:
    1
    Assembly 'Packages/com.unity.ads/Editor/UnityEditor.Advertisements.dll' will not be loaded due to errors:
    Unable to resolve reference 'UnityEditor.iOS.Extensions.Xcode'. Is the assembly missing or incompatible with the current platform?
    Reference validation can be disabled in the Plugin Inspector.

    NullReferenceException: Object reference not set to an instance of an object
    UnityEngine.Advertisements.Advertisement.Initialize (System.String gameId, System.Boolean testMode) (at /home/builduser/buildslave/com.unity.ads/package/Source/UnityAds/Advertisement.cs:210)
    AdsManager.Awake () (at Assets/Scripts/AdsManager.cs:52)
    (This line of code is just Advertisement.Initialize(gameID, testMode);)

    I can assure that no script directly uses that namespace, unless it's under the hood of it. I have ads enabled, and am on the android build platform.
    I've had this happen twice to me so far, the first time i fixed it by doing random things, e.g changing the scripts that handle the advertisements, restarting unity, etc.
    I haven't done anything unusual to make it pop up, as i've just closed unity while the ads were working perfectly, and after reopening it, it showed the error.
    My only assumption is that google play might be blocking my pc as i had override test mode on in the dashboard, but the ads incorporated are the ones built into unity?
    Currently running on version 2019.2.3f1

    I've tried checking other threads before posting, but there seems to be very limited info on this issue, unless i've not searched deep enough.
    This is for an update on a game that's already uploaded to google play, i don't think this issue happened before i uploaded it, although i did downgrade from the 2019.3 alpha.
    Apparently on a test build (before this issue popped up) the ads seem to work,
    The google play build (not this one) seems to have the ads working as well, so the error is either local or there's an error in the code, though i doubt that. I can provide the code if needed.
     
    Last edited: Sep 11, 2019
  2. markobozic346

    markobozic346

    Joined:
    Apr 21, 2019
    Posts:
    1
    same problem, any solution ?
     
    ao02 likes this.