Search Unity

Advertisement not loading...

Discussion in 'Unity Ads' started by CastleIsGreat, May 27, 2015.

  1. CastleIsGreat

    CastleIsGreat

    Joined:
    Nov 10, 2014
    Posts:
    179
    Before reading this, I've been awake for well over 19 hours, and my caffine is wearing off, so if this makes no sense just try to follow my rambling...

    Hi, when my game is in developer mode, and test mode is enabled, the test ad appears as it should. However I am prepping for launch, and have just created a build with dev mode off, and test mode off, and when I run this through the debugger in xcode, the version I have does not seem to want to load an advertisement, and instead leaves my game stuck, as the end result of either completed, skipped, or failed is apparently not loading.

    This could have been caused by a couple of things, so I'll just throw them out there.

    Scenario : Particularly, I'm trying to test whether my no advertisement penalty works. To do this, I cant have test mode on, as test mode always assumes the advertisement completed and never failed. THAT BEING SAID... I am trying to make that load fail so the penalty message pops up with retry advertisement/play with penalty option. Mostly to avoid people just turning on airplane mode to avoid advertisements, while allowing people to play who want to play and are actually on an airplane or other things and dont really care about the in-game money they're making, as long as they can play while not connected.

    So, could this hang up have been caused by

    A. When unity ads initializes, does it pull zones then from the internet? Meaning no internet, no initialization? which would then result in no advertisement ever being ready, which would then cause my game to get hung up (temporarily I'm writing in an isready check as we speak to catch that possibility) far before it reaches advertisement play failure
    Infact the solution I may be looking for in actuallity may be right in front of me, ill post again once I test this, it may have actually been because of the advertisement never initializing and it dieing out before it ever got to failure which is the fail safe for if there is no internet etc. but if it breaks before it ever gets there that would explain the hangup... anyway, I'll post back to see if I need to add a B.

    Suuuureeee eeeenough, that has to be it the ad worked the second time I tried it (with plane mode turned off), it was that the initialization had not pulled campaigns, so in other words I need to catch the no internet thing at either isinitialized or isready rather than looking for video failure to determine internet outage... ANYWAY, I submit for the app store in a couple of hours, so just ironing the very very end stage things...

    www.nanitegamingstudio.com
     
    Last edited: May 27, 2015