Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Question Ads and Play Games Services not working after change of package name

Discussion in 'Formats & External Tools' started by niklas_fruehling, Oct 30, 2020.

  1. niklas_fruehling

    niklas_fruehling

    Joined:
    Oct 1, 2020
    Posts:
    1
    Hey,
    I added Google Play Games Services, Google Admob and Unity Ads to my Android game. Tested it and everything worked fine.
    Now I changed the package name of the app. There already is a new entry for this in the Play Store and I updated the resources file for the play games plugin in Unity.
    But here is the problem, after changing this none of the plugins does work anymore. At least not in the .aab-file, in the editor everything works just fine. So if I'm in Unity, Unity Ads do still work and I still get debug-log from Admob, but when I build the .aab-file and release it as a test via Google Play neither ads nor Play Games Services do work.
    What I noticed is that the .aab-file now is a bit smaller than before (not much but 2 or 3 MB), so my guess is that Unity does build the game without plugins. I have no idea how to fix this, does someone has an answer to this problem?
    Thank you in advance!

    Edit: Problem solved. Copied project to a new folder and resolved Android dependencies (which also worked in the old folder but did not solve the problem). That's it.
     
    Last edited: Oct 30, 2020
    niraj_gajera_01 likes this.
  2. Baik_Oussama

    Baik_Oussama

    Joined:
    Oct 9, 2018
    Posts:
    7
    I'm having the same issue, can you please elaborate on what did you do exactly? did you create a new folder and copied the assets, library, logs...folders to the new one?