Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Question (Addressables) Unable to load asset bundle

Discussion in 'Package Manager' started by islamagdy111, Oct 29, 2022.

  1. islamagdy111

    islamagdy111

    Joined:
    Oct 29, 2019
    Posts:
    19
    Hi there..
    I'm new to addressables, I followed this tutorial on youtube (
    ) and I made it, so I was able to make my prefab level downloaded from cloud at the beginning of the scene as a test. everything was fine, then I mad some changes and updated the addressable build. and from here it stopped working at all...
    I tried everything, I also started all steps from beginning and no luck.
    it says in unity console (RemoteProviderException : Unable to load asset bundle from : (Link)... ResponseCode : 404), I tried Unity dashboard and digitalocean to upload assets.
    I'm using android platform

    anyone know what is the problem here???
     
  2. islamagdy111

    islamagdy111

    Joined:
    Oct 29, 2019
    Posts:
    19
    at last I did it, it was nightmare for days.
    for those who have the same problem:
    the steps have to be in exact specific order...
    1- run setup guide in unity dashboard /LifeOps/Cloud Content Delivery, (upload any small file for now).
    2- go to your bucket and copy the url with the latest badge (Not the release one).
    3- put the url link in unity Addressables Profiles / RemoteLoadPath.
    4- build the addressables group.
    5- delete the small file (in number 1 of this steps), and upload the files from ServerData to your bucket.
    6- create new release.
    and you are done :)

    * if you promoted the release => start from number 4 again and follow the steps
    * if you made changes to groups => update the addressables group, then follow steps from number 5