Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

"Add Modules" missing for 2018.4.2f1 install

Discussion in 'Unity Hub' started by anthonyblackman, Jun 27, 2019.

  1. Tony_D7

    Tony_D7

    Joined:
    Oct 28, 2020
    Posts:
    4
    Thank you for the editor.json file trick, it did work ! the " add modules " option poped-up. Only to tell me that " no modules were found ofr unity 2020 " . :D At this point i don't even get mad anymore. I know that whatever installation, changes, pretty much whatever is going to end up on internet to fix problems, and that one problem will lead to another problem etc, etc.. So, hum, what do i do now ??
     
  2. MythicalCity

    MythicalCity

    Joined:
    Feb 10, 2011
    Posts:
    420
    Same here, I can't get this to work. On Mac, I tried editing the editors.json, and deleting it even. But the version I want to actually add modules for is the only one that doesn't have that option. It was downloaded with the hub.

    And of course if I try to download the modules from the archive separately, I get an "installer error" when I try to run the install.... so no apparent way to do this without deleting and reinstalling the entire editor with the modules.

    Are there any official solutions or just hacks and workarounds created by the community? Because if so, Unity should hire some of the devs on this thread :)

    We just want to use unity :) (especially since we pay for a pro license)
     
    Last edited: Jul 27, 2021
  3. lehailam016

    lehailam016

    Joined:
    Oct 23, 2021
    Posts:
    2
    It work, but it display "No module were found in Unity {Version}" can you help me? upload_2021-12-5_12-19-13.png
     
  4. lehailam016

    lehailam016

    Joined:
    Oct 23, 2021
    Posts:
    2

    it work but uh
    upload_2022-1-18_14-10-31.png
     
  5. NeoSong1215

    NeoSong1215

    Joined:
    Apr 21, 2022
    Posts:
    1

    This one really works for my case but notice that you have to exit the unity hub totally before you modify the editors.json file. I failed many times just because I click the exit button of unity hub while in fact it was still running. I found it in task bar and exit totally then this worked!
     
  6. Vape-dere

    Vape-dere

    Joined:
    Jun 4, 2022
    Posts:
    1
    For win 3.1.2 ver:
    C:\Users\?????\AppData\Roaming\UnityHub\Templates\manifest.json Add "manual":false
    Should look like this {"2021.3.4f1":{"dependencies":{"com.unity.template.fps":"4.0.0"}, "manual":false}}
     
  7. CiroContns

    CiroContns

    Unity Legend

    Joined:
    Jan 28, 2008
    Posts:
    95
    With the new Hub (3.3) the solution proposed by ahmetilhan282 didn't work for me.

    However, downloading the Unity Installer from the archive page did the trick. Not the Editor (single download), mind you, but the Installer.

    If you have the editor already installed, after you select the modules the Installer will sometimes complain that to add them it needs Unity to be installed on the system. If that happens, either reinstall Unity from scratch where it wants, or temporarily move the Unity executable to where the Installer expects it to be, install the modules, and then move it back. For me, on Mac, it was
    /Applications/Unity/
     
  8. GrassWarlock

    GrassWarlock

    Joined:
    Dec 25, 2022
    Posts:
    1
    Solution:
    i wanted to download Android build support for a unity editor i installed outside of the hub.
    i went to the download archive, found the editors version, clicked on downloads, downloaded the unity installer. from the installer you can pick the modules. make sure to choose the correct install location corresponding to the editor you want the module to apply to.
     
  9. alexvee

    alexvee

    Joined:
    Dec 22, 2020
    Posts:
    1
    Thank you so much, but now unity wants me to install a newer version of the editor because there are no modules to install... lol.
     
  10. PasMol

    PasMol

    Joined:
    Feb 5, 2016
    Posts:
    12
    The "Add Module" feature in Unity Hub v3.5 needs a modules.json file:
    • C:\Program Files\Unity Editor\2023.1.5f1\modules.json
    The exe file in this case will be located in the folder:
    • C:\Program Files\Unity Editor\2023.1.5f1\Editor\Unity.exe
    The modules.json file contains direct links to download components. All links are unique for different versions.
    Code (CSharp):
    1. {
    2.     "url": "https://download.unity3d.com/download_unity/9dce81d9e7e0/TargetSupportInstaller/UnitySetup-Linux-IL2CPP-Support-for-Editor-2023.1.5f1.exe",
    3.     "integrity": "md5-NWI1ZGI0MjA3N2Q0MDBjYWM5ZmNlMTJlNDg3ZmMyNGE=",
    4.     "type": "EXE",
    5.     "id": "linux-il2cpp",
    6.     "name": "Linux Build Support (IL2CPP)",
    7.     "slug": "2023.1.5f1-windows-x86_64-linux-il2cpp",
    8.     "description": "Linux Playback Engine (IL2CPP Scripting Backend)",
    9.     "category": "Platforms",
    10.     "downloadSize": 56046592,
    11. .....
    Here you need to replace 9dce81d9e7e0 and replace version 2023.1.5f1
    You can find the hash code 9dce81d9e7e0 for v2023.1.5f1 on the page:
    https://unity.com/releases/editor/whats-new/2023.1.5
    The hash code is indicated at the very end of the page:
    • Changeset: 9dce81d9e7e0
    And also the page has links to download the Unity Installer:
    https://download.unity3d.com/download_unity/9dce81d9e7e0/UnityDownloadAssistant-2023.1.5f1.exe

    The modules.json file has a problem with the OpenJDK download link:
    Code (CSharp):
    1. {
    2.     "url": "https://download.unity3d.com/download_unity/open-jdk/open-jdk-win-x64/jdk11.0.14.1-1_85218201fea144521d643808d167605d6d46cd4fe44ee4001991a3a4b76fdd64.zip",
    3.     "integrity": null,
    4.     "type": "ZIP",
    5.     "id": "android-open-jdk-11.0.14.1+1",
    6.     "name": "OpenJDK",
    7.     "slug": "2022.2.21f1-windows-x86_64-android-open-jdk-11.0.14.1+1",
    8.     "description": "Android Open JDK 11.0.14.1+1",
    9.     "category": "Platforms",
    10.     "downloadSize": 120395628,
    11.     "installedSize": 233683479,
    12. ....
    If you are using version 2022.3, then most likely you need to find the modules.json file from other versions of 2022.x and make changes to this file.
    In this case, version 2021.x is not suitable, because it uses a different version of the JDK and its version is indicated in the table on the page:
    https://docs.unity3d.com/2023.2/Documentation/Manual/android-sdksetup.html
     
    Last edited: Aug 28, 2023
  11. ASymShade

    ASymShade

    Joined:
    May 18, 2018
    Posts:
    6
    I don't think this reasoning is good.

    Firstly the user is still required to pick between the kinds of major versions in the Hub like 2019.x or 2020.x given in the example anyway (and there's no realistic way to remove this choice). But if you did additionally want to limit the most casual users from selecting between only the most recent versions, you could do it without hindering everybody else by having a checkbox like "Only show most recent releases" that is checked by default. For users working on platforms like consoles where additional plugins are required to use the platform, it can take a week or so for the plugins to be released, by which time another editor minor version may have been released, making the Hub selector unusable in this case.

    The real problem, though, is Unity Hub installs subtly behaving differently from direct downloads in a way that is never explained upfront until you months later try to change modules and realize you ended up with a crippled install that opaquely doesn't support it (by the way, the Editor.json workaround seems to no longer work with recent versions of Hub). If this were fixed, not being able to download older minor version releases from within the application wouldn't be a big deal, but as of now unlike transparently giving an option to access to older minor versions from within the Hub, this is a genuine usability problem.

    I don't understand why this behavioural difference exists (presumably Hub needs some metadata that may not exist unless it was installed through Hub, but this surely could be included in the independent installers as well, and if so probably should have been the case with new installers since the initial introduction of Hub). However, if for some reason it is genuinely unresolvable, older versions should be selectable from Hub or, at the very least, there at least should be a pop-up warning with each independent download explaining that installing it will prevent you from being able to add modules afterwards. Currently the Hub selector is basically subtly directing users to make bad choices for the majority of use cases.
     
  12. Stonegolemstudio

    Stonegolemstudio

    Joined:
    Feb 26, 2022
    Posts:
    13
    Yep that was it. You can't "Manual" add the version you have actually click the "Unity Hub" button and that lets you get the JDK/SDK etc as well. God horrific UI and navigations
     
  13. KumarTony

    KumarTony

    Joined:
    Jun 14, 2023
    Posts:
    41
    ithank you 1st thing from forum worked for me
    but need to see another problm will solv or not (verification failed problem)