Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Acclaration on current package version when on 2021.3

Discussion in 'Burst' started by Whipexx_DigitalSun, Aug 24, 2022.

  1. Whipexx_DigitalSun

    Whipexx_DigitalSun

    Joined:
    Aug 8, 2017
    Posts:
    16
    Hi there! I've read that the current verified version is 1.7.4 (and has been 1.7.x for quite some time). I'm a bit confused as to why is this version not available directly on the package manager. It can be downloaded manually from there but even then a message is shown recommeding the 1.6.6 over the newer one.

    Also, the last patch notes that mention changes to the Burst package is 2021.3.6, updating from burst 1.6.5 to 1.6.6.

    Why is this incongruence?
     
  2. sheredom

    sheredom

    Unity Technologies

    Joined:
    Jul 15, 2019
    Posts:
    300
    With later Unity editors there are new package manager rules that we have to follow such that newer packages only appear in newer editor versions. We (the Burst team) ensure that Burst works on all currently supported editors (so all the LTS versions + the latest), but we can't show this in the package manager UI because of these rules.

    Annoyingly these rules don't seem to be canonically written out anywhere public that I can find, so I've raised this issue with the package manager team internally here at Unity. Feel free to ask over at https://forum.unity.com/forums/package-manager.150/ though too!
     
    Whipexx_DigitalSun likes this.