Search Unity

  1. The 2022.1 beta is now available for testing. To find out what's new, have a look at our 2022.1 beta blog post.
    Dismiss Notice

a very weird bug. URP particles shader problem

Discussion in 'Universal Render Pipeline' started by afshin_a_1, Apr 17, 2020.

  1. afshin_a_1

    afshin_a_1

    Joined:
    Apr 26, 2015
    Posts:
    33
    i recently wanted to use explosion effect from unity particle pack(which is in built-in renderer) in my project(urp).
    i came up with changing the material shader from *particles/standard unlit* to *URP/Particles/Unlit* very easly.
    everything changed correctly. even is ok when testing in editor play mode. there is only one wierd problem. when testing in play mode (game view maximize) or the output on android device some part of the particles doesn't render.
    i tested this problem in three different projects including unity's urp template project, same result.

    target build: android
    unity 2019.3.9
    urp 7.3.1

    here is the screenShot and project itself(test version).
    https://drive.google.com/open?id=1IA7kaWN2qKfS4jBik9RIrD7KLAkcL2mH
    showing.jpg not showing_bug.jpg
     
    Utdan likes this.
  2. Elvar_Orn

    Elvar_Orn

    Unity Technologies

    Joined:
    Dec 9, 2019
    Posts:
    129
    Hey,
    Do you have soft particles enabled on your particle material? If yes, do you have depth texture enabled in the UniversalRenderPipelineAsset ?
     
  3. MrKarlsson

    MrKarlsson

    Joined:
    Jan 4, 2020
    Posts:
    1
    Thank you for this sollution Elvar_Orn, I had the same problem and this solved it for me!

    Cheers!
     
  4. Elvar_Orn

    Elvar_Orn

    Unity Technologies

    Joined:
    Dec 9, 2019
    Posts:
    129
    Good to hear :)
    I will make a PR, hopefully next week, that addresses this issue. Basically soft particles need the depth texture in order to work correctly but we need to warn people when Depth Texture turned off in the Asset plus also prevent particle disappearing in builds.

    Should be pretty straightforward to do and I think I can squeeze it in the next release if all goes well.
     
    MrKarlsson likes this.
  5. afshin_a_1

    afshin_a_1

    Joined:
    Apr 26, 2015
    Posts:
    33
    I can confirm that the problem was solved by enabling depth texture. i didn't notice that because all i used was default urp settings and default unity particles itself.
    - that particles problem solved but still there is an issue with visual differences vs built-in renderer one. you can see this by checking Shockwave Particles in unity particle pack.
    - also i came up creating a custom urp particles shader with hdr color for base map because of another visual differences.
     
    blutcat likes this.
  6. Nirmal_Amaladhas

    Nirmal_Amaladhas

    Joined:
    May 7, 2018
    Posts:
    2
    Soft particles not working on 2019.4.28 , URP version 7.6 and 7.7
    I have enabled depth in the URP asset, also tried with and without opaque which is not working. Noticed this issue is not seen in 2020 Unity. Is there any fix for this ?
     
    Last edited: Jul 9, 2021
  7. oleg_v

    oleg_v

    Joined:
    Nov 10, 2017
    Posts:
    54
    Unity 2020.3, URP 10.5, Unlit/Particles shader with Blending mode = Multiple not visible in Editor. But visible in Play mode.
    Specific: paticles are only trails, vertex color is mostly red with alpha transitions, shader base color is white, texture with alpha (255 in center), emission color is enabled/disabled - doesn't matter.
    All advanced options, including "Soft particles" are disabled.
     
unityunity