Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

99% load on integrated GPU. How to set fixed frammerate?

Discussion in 'Project Tiny' started by Fotal, Oct 4, 2020.

  1. Fotal

    Fotal

    Joined:
    Apr 9, 2019
    Posts:
    38
    Hi, when I run games on Unity Tiny on laptops that use an integrated GPU, they load it 95 - 99% in Google Chrome.

    Can I setup a fixed framerate in Unity Tiny or fix this issue in another way?
     
  2. AbdulAlgharbi

    AbdulAlgharbi

    Unity Technologies

    Joined:
    Jul 27, 2018
    Posts:
    319
    Hi,
    We currently don't support fixed framerate
    but I wonder do you have Vsync enabled?
    and would be great if you share your device specs so we can try that internally
     
    Fotal likes this.
  3. Fotal

    Fotal

    Joined:
    Apr 9, 2019
    Posts:
    38
    Yes, we have enabled Vsync option.
    This problem with a load on GPU reproduced mostly on laptops, when Google Chrome or another browser uses not a video card but an integrated graphic processor.
     
  4. AbdulAlgharbi

    AbdulAlgharbi

    Unity Technologies

    Joined:
    Jul 27, 2018
    Posts:
    319
    Thanks I'll report this internally
     
  5. bkaradzic-unity3d

    bkaradzic-unity3d

    Unity Technologies

    Joined:
    Jan 17, 2020
    Posts:
    17
    @Fotal Could you provide laptop specs (CPU/GPU/OS/drivers info).
     
  6. Marulian

    Marulian

    Joined:
    Jan 18, 2014
    Posts:
    4
    I have a Desktop and a Laptop.

    I don't know if this is related, but I can reproduce these symptoms by disabling hardware acceleration in the browser settings of Microsoft Edge in my desktop with windows 10 Pro.

    With Hardware Acceleration Off I get low framerates and high CPU usage, everything is fine if turned on.

    Now over at my laptop, in Linux with google chrome and Hardware Acceleration On I get 100% CPU usage in a single thread, but no low framerates, the game appears to be smooth. My laptop is always running on the Nvidia video card, it doesn't have Nvidia Optimus or something like that to switch on the fly so I set it to always use the Nvidia GPU.

    This was tested with the github example links over at https://github.com/Unity-Technologies/ProjectTinySamples

    My Desktop:
    Ryzen 9 3900x
    RTX 2070S
    32gb RAM
    Windows 10 Pro

    My Laptop:
    i7-9750H
    GTX 1650
    16gb RAM
    Ubuntu 18.04.5 LTS

    Hope this helps in something.
     
  7. bkaradzic-unity3d

    bkaradzic-unity3d

    Unity Technologies

    Joined:
    Jan 17, 2020
    Posts:
    17
    > With Hardware Acceleration Off I get low framerates and high CPU usage, everything is fine if turned on.

    This is expected. If CPU is emulating GPU functionality you would get high CPU usage, and low frame rate since GPU is way better at doing rasterization than CPU emulation.
     
  8. Marulian

    Marulian

    Joined:
    Jan 18, 2014
    Posts:
    4
    Yeah that was expected, but the behaviour in my laptop is not.

    Just tested again in a google chrome tab, almost 100% CPU usage with hardware acceleration on, not sure if it's the same problem as @Fotal since I'm testing in linux, I'll boot into windows later and let you know if the problem persist.
     
  9. Fotal

    Fotal

    Joined:
    Apr 9, 2019
    Posts:
    38
    Hi, thanks for waiting, I didn't notice the notification)
    My specs:

    CPU: Intel® Core™ i7 6gen 6700HQ 2,6 - 3,5 GHz
    RAM: 16 GB RAM
    Space: 256 GB SSD + 128 GB SSD
    GPU: nVidia® GeForce GTX960M + Intel HD Graphics 530
    OS: Windows 10
    Nvidia Driver: 418.91

    At the moment, my team and I have the same GPU load rates, as it was, tested on the new Demo (I wrote about this in a new Demo thread)
    On mobile phones, we have the normal framerate, but phones also get very hot over time.