Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

5.6 shadowmask issues

Discussion in 'Global Illumination' started by Warrior1424, May 6, 2017.

  1. Warrior1424

    Warrior1424

    Joined:
    Sep 30, 2010
    Posts:
    983
    I have 8 mixed spotlights in my scene with a static environment.
    I'm in forward rendering.
    I'm using the shadowmask mode for the mixed lighting.
    There is no light overlap.
    This setting allows for baked lighting on static objects, realtime shadows from dynamic objects, and lightprobes for light occlusion on dynamic objects.

    However, when too many of these lights are in view, they begin turning off (or possibly switching to vertex lighting), as seen with the limitations of realtime lights in forward rendering.
    How can this be happening if the light is baked into the environment? Is this a bug? Am I not understanding the shadowmask mode?

    Edit: Here's a video showing it in action
     
    Last edited: May 13, 2017
  2. Warrior1424

    Warrior1424

    Joined:
    Sep 30, 2010
    Posts:
    983
    Maybe I should just submit a support ticket or something?
     
  3. will54321

    will54321

    Joined:
    Aug 7, 2017
    Posts:
    4
    Change the rendering mode of light to important, it should be auto by default
     
  4. kemalakay

    kemalakay

    Unity Technologies

    Joined:
    Jul 12, 2016
    Posts:
    224
    Hi,

    Besides changing the rendering mode of your lights, you can also go to Edit > Project Settings > Quality Settings and increase Pixel Light Count under Rendering section from 4 to any other number. This parameter is for forward rendering path.
     
unityunity