Search Unity

5.3.5 not compatible with DK2?

Discussion in 'AR/VR (XR) Discussion' started by Pawige, May 21, 2016.

  1. Pawige

    Pawige

    Joined:
    Nov 26, 2012
    Posts:
    29
    I'm guessing it is not, because when I tried to run a project in 5.3.5 with a DK2 I get a black screen, and there's this line in the release notes:

    • VR: Updated Oculus API and plugin to version 1.3.2. Downloading 1.3.2 OVRPlugin from Oculus is no longer necessary.

    If that is the case, are there any workarounds possible?
     
  2. JDMulti

    JDMulti

    Joined:
    Jan 4, 2012
    Posts:
    382
    Weird, it worked in version 5.3.4p6. I hope they didn't remove DK2 support, that would be crazy!
     
  3. ikriz

    ikriz

    Joined:
    Dec 3, 2009
    Posts:
    91
    Using a DK2 Running:

    Unity v5.3.5f1
    Oculus Utilities v1.3.2
    OVRPlugin v1.3.2
    Oculus SDK v1.4.0
    Virtual Reality Supported == true.

    [edit]
    Prior to all this the most recent nvidia driver didn't work so i rolled back to 362.56 which got the DK2 working so i could at least get through the Oculus Setup. CV1 still remains black during setup tho.
    [/edit]

    For some reason the Main camera (non ovr-rig) shows a vertical blue band along the right side of the editor game view (guessing that is the background color) HMD remains black.

    Running same scene (any scene, including example scenes) with the OVRCameraRig renders correctly (no blue band) but still nothing on HMD. Standard scene (main cam and directional light with a cube) results in strange blue band behavior (possibly camera eye offset artifact?)

    The Oculus Home / Store application thing works fine, albeit with a notice of degraded performance, which I can live with.
    Didn't download OVRPlugin from Oculus (as release notes state).

    P.s. Thought it might have been the "Unknown Sources" setting in Oculus settings but didn't help anything (https://support.oculus.com/878170922281071)
     
    Last edited: May 23, 2016
  4. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    Given the the Oculus runtime 1.3.2 does work with the DK2, if its broken in Unity I'm sure its by accident rather than design. I cant try right now but will try tonight.
     
  5. ikriz

    ikriz

    Joined:
    Dec 3, 2009
    Posts:
    91
    Pinpointing the issue is a real bummer at the moment, there are so many components in the mix, DK2 is supported according to Oculus, just future updates may break. I'm leaning towards display driver issue or unity issue.

    Rolled back to Oculus Runtime 0.8.. HMD remains black, Oculus desk demo scene is fine.
     
    Last edited: May 23, 2016
  6. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    OK I tried and it worked absolutely fine for me.

    Win 10 64 bit, DK2, Oculus 1.3.2 drivers/runtime stuff, nvidia GTX970, Unity 5.3.5 64-bit. Tried nvidia driver version 365.10 and then updated to 368.22, worked no problem with either.
     
  7. ikriz

    ikriz

    Joined:
    Dec 3, 2009
    Posts:
    91
    I have it working in 5.3.4f1 with the Oculus 0.8 runtime no problem, had to because of critical project deadline.
    Using Win 7 64bit, Nvidia Quadro K5000M (yes running on a laptop, yes i know oculus doesn't support laptop, has always worked)

    suspecting the nvidia drivers as you are running a geforce card.
     
    Last edited: May 24, 2016
  8. HankySpanky

    HankySpanky

    Joined:
    Feb 3, 2015
    Posts:
    77
    I'm also having an issue with the DK2.
    It was fine before installing 5.3.5. Now I just get this error on play:


    I'm using a GTX970 with the latest driver (368.22) installed. No luck.
     
  9. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    Did you move to Oculus runtime 1.3.2 or are you still using 0.8.0? I dont think its going to work on significantly older oculus runtimes.
     
  10. Macklin

    Macklin

    Joined:
    Jun 13, 2015
    Posts:
    8
    I have the exact same problem. In the editor I get a blue bar along the right side of the view port, and a blank screen on the HMD (although head tracking/input works fine).

    Running Unity 5.3.5f1, DK2, Win 8.1, Quadro K2200 (with "VR/Performance" driver 364.72), plus all the stuff bundled with OculusSetup.exe - the Oculus Home client and the 1.4 runtime. I don't have the Oculus Platform SDK or the Oculus PC SDK installed, as neither were required previously - and I'm not using any of the functions they provide.

    After experimenting, I've found that the Oculus client needs to be running alongside the Unity Editor, or at least while testing VR in play mode. While the client is automatically started with the editor, and in standalone builds (given the OVRService is running, and you have "Virtual Reality Supported" checked in player settings), if it is closed, in play mode the HMD will be blank and the editor view port will display a blue bar on one side. Restarting the editor, or manually starting the Oculus client before entering play mode seems to solve this easily.

    Since it is a bit intrusive, I feel a lot of people could mistakenly close the Oculus client just after it opens with the editor, assuming it would continue to run in the background. Ideally, Oculus should add an option which minimizes the client to the system tray when it's closed from the UI (like Steam or Battlenet does), or even the ability to open the client directly to this state, so that applications that open it automatically aren't disturbed. Unity could probably also warn the user if the Oculus client isn't open during play mode, and a rift is connected. Nevertheless, the entire process of funneling every Oculus-enabled app through the client seems bulky and unnecessary - where previously it was fairly minimal.
     
  11. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    The whole running battle with people breaking the 'store apps only work on rift hardware' protection is really not helping matters on the perception and it looks like you've run into an implication of it for developers - if Oculus want people to receive an update for 'security' reasons, they are going to push stuff out and not offer easy ways to roll back/prevent the update? Or is there a way to turn that update stuff off? Oh dear, the ugly realities of the thing being so strongly tied to a store/drm platform. At this rate I'm not sure I will ever own an Oculus besides the DK2.

    Anyway well done Macklin for potentially finding the solution to some peoples issues - I always had the oculus app open and I'm the one that reported DK2 working fine with 5.3.5, so that could well be the differentiating factor between my success and others failure to get it working.
     
  12. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    When I say tied to a store/drm platform, I know that the rift hardware can run stuff that isn't from their platform, so we aren't tied to that platform in terms of distributing our apps. But clearly issues of drm/locking etc that exist on their store still have the potential to leak into the lives of dev in unwelcome ways.
     
  13. Todd-Wasson

    Todd-Wasson

    Joined:
    Aug 7, 2014
    Posts:
    1,069
    I had really hoped that Unity would be totally Oculus ready by the time the CV1 was released, but from this and other threads it looks like people are having a lot of problems. I've been running 5.2.3p3 for a long time now with DK2 + 0.8 runtime and it's great (plenty fast enough for my product but more is always welcome of course), but would like to move up to 1.3 runtime so I can promote my product as having proper Oculus Rift support. I've got at least one guy dying to buy it for his CV1, but he's got to wait because I'm still on 0.8 runtime.

    Is there any Unity 5.3 version that supports 1.3 pretty reliably without too many headaches introduced into basic workflow? I don't dare touch the beta version although I would really like to see the single pass magic. Some folks are reporting astonishing performance increases. I'm trying to decide whether to just take the plunge now or wait another month or two and see how things are. It looks like it might be a bit early still for me to go for the update.
     
  14. Todd-Wasson

    Todd-Wasson

    Joined:
    Aug 7, 2014
    Posts:
    1,069
    I'll take that as a "no." :rolleyes:
     
  15. elbows

    elbows

    Joined:
    Nov 28, 2009
    Posts:
    2,420
    I'd always recommend trying yourself, after taking sensible steps such as backing up project and installing different unity versions to different places so you can run more than one version on a machine without reinstalling etc.

    I saw this because forum user experiences often vary widely, some problems that show up here are far from show-stoppers to everyone. Especially with VR, where runtime & driver issues are sometimes responsible for some problems. And what counts as basic workflow to one person isn't necessarily so to another.
     
  16. Todd-Wasson

    Todd-Wasson

    Joined:
    Aug 7, 2014
    Posts:
    1,069
    Thanks. I'm set up to run multiple Unity versions, but updating is often a bit scary when going from 5.1 to 5.2 or 5.3 because of the massive recompilation of scripts that often needs to be done (30-45 minutes on my project). Occasionally something will break. Just wondered if somebody might save me some time and trouble by sharing their experience. It's happened before but apparently not this week. ;)
     
  17. vrc2016

    vrc2016

    Joined:
    May 18, 2017
    Posts:
    1
    someone knows how to fix unity beta 5.6 f02 to dk2 ? because i can not get in to vr , i installed Runtime v0.8.0.0 (oculus configuration utility version 1.10 (sdk 0.8.0.0)), that this version worked with my unity 5.3

    Unity v5.6.0f2,
    Oculus Utilities v1.3.0,
    OVRPlugin v1.12.0,
    SDK v0.0.0.
    vr==true

    not work
     
    Last edited: May 18, 2017
  18. Sudarto

    Sudarto

    Joined:
    May 3, 2017
    Posts:
    5
    Vrc2016 you need to update Runtime SDK , but i dont know what runtime that work with DK2 beside 0.8.0.0
     
  19. Todd-Wasson

    Todd-Wasson

    Joined:
    Aug 7, 2014
    Posts:
    1,069
    I'm using DK2 on 5.5.2p2 and current Oculus runtimes. It works fine.
     
unityunity