Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

3ds max users - Deselecting verts during envelop editor

Discussion in 'Animation' started by jessee03, Sep 3, 2013.

  1. jessee03

    jessee03

    Joined:
    Apr 27, 2011
    Posts:
    700
    I was wondering if anyone knows how to Deselect verts during the envelop editor. It's very frustrating because I'm doing simple animations and my bone structures are always animating verts that I don't want to be animated when I move those bones. I've tried a lot of tutorials but cannot seem to figure it out.
     
  2. Foestar

    Foestar

    Joined:
    Aug 12, 2013
    Posts:
    343
    Not really sure what you mean? You mean when you animate your object it's moving some of the verts that you don't want it to? If this is the case then just adust your envelope so as to not include those verts by adjusting it's size and or parent/child overlap which can be found under your physique/envelope. If you're trying to alter the vert itself then select the vertex option under the same location and adjust accordingly there.
     
  3. jessee03

    jessee03

    Joined:
    Apr 27, 2011
    Posts:
    700
    If you're skinning an object with bones, you are able to Select a bone and then edit envelops which can be used to Select which parts of the model animate when moving the bones. My problem is when I adjust the nodes on the bones there's no way to Select less verts it seems. I want to be able to directly Select which verts animate when moving the bones.
     
  4. Swearsoft

    Swearsoft

    Joined:
    Mar 19, 2009
    Posts:
    1,631
    You select the bone that is influencing the vertex, you also select the vertex that is moving, you then reduce the bone weight to zero.
     
  5. Binderysc

    Binderysc

    Joined:
    Aug 15, 2016
    Posts:
    1
    Foestart, I used what you have stated here. It does help me a lot. I do not have any issue at all about few verts that are moving even if I do not want them too. Thumbs up, mate!