Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Resolved 3DMouse giving constant "Horizontal" axis inputs

Discussion in 'Input System' started by Sqwert, Mar 20, 2021.

  1. Sqwert

    Sqwert

    Joined:
    Apr 27, 2017
    Posts:
    12
    I use a Space Mouse to move around Scene, problem is when I use Input.GetAxis("Horizontal") for example Iám getting constant readings from the 3DMouse.

    IS there any solution to this other than removing the 3DMouse?
     
  2. Sqwert

    Sqwert

    Joined:
    Apr 27, 2017
    Posts:
    12
    Resolved - Uncheck "Runtime editor Navigation"
     
  3. K-tal

    K-tal

    Joined:
    Nov 15, 2021
    Posts:
    1
    Thanks for the solution but, I couldn't find where you were referring to "Runtime editor Navigation" as an option to untick.

    But an alternative is to go to Edit>Project Settings>Input Manager and select both Horizontal and Vertical and set "Joy Num" to 10 on each. And note that there are 2 (TWO) options for Horizontal and Vertical so you need to change both. (no idea why there are 2).

    I don't know if this a complete solution but it's initially working for me. But, just in case it would be good to find "Runtime editor Navigation" just in case that a more wide-ranging solution.