Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question 2D Blend Tree breaking on rear left / forward right diagonal

Discussion in 'Animation' started by redblue85, Aug 28, 2023.

  1. redblue85

    redblue85

    Joined:
    Aug 28, 2023
    Posts:
    4
    I'm trying to make a 2D blend tree for my general purpose walk cycles, but it seems like one of the diagonal directions is not syncing properly. I've tried to test as much as I know how to, which includes swapping models and animations, but no changes. Can somebody explain to me like I'm 5 why this is happening?

    Key points:
    1. All of these animations are using the humanoid rig, as are my models. I've checked them and don't see any obvious errors, which is to say I didn't see any red in the configuration.
    2. The right strafe animations are just a mirrored duplicate of the left which I downloaded from mixamo. These should be exactly the same.
    3. It occurs regardless of what forward/backward animations I use. I have tried both unity-chan walk/run cycles and a set from mixamo.
    4. It seems to occur on all models, even on the default unity model.
    5. For compatibility reasons I'm stuck on unity 2019.1.1.11f1. Upgrading will break scripts I can't afford to break.

    I took a video capture of what's going on and posted it here: https://gifyu.com/image/SgWZh
    I am aware of the fact that the right strafe animation says "old", I was swapping those and it doesn't help either.
    When I disable IK in the preview window, it looks like the feet always want to move in the same diagonal direction no matter what the coordinates are. https://gifyu.com/image/SgWYm
     
    Last edited: Aug 28, 2023
  2. redblue85

    redblue85

    Joined:
    Aug 28, 2023
    Posts:
    4
    After redownloading all my animations and reimporting them, the issue is a lot less severe, however that being said it is still very apparent in the back right. The feet are still crossing over each other in that quadrant for some reason.
    https://gifyu.com/image/SgWBj
     
    Last edited: Aug 28, 2023
  3. fideltfg

    fideltfg

    Joined:
    Sep 5, 2014
    Posts:
    10
    Hi, Did you find a fix for this? I'm having the same issue with a bunch of my animations,
     
  4. redblue85

    redblue85

    Joined:
    Aug 28, 2023
    Posts:
    4
    Not really. When I redownloaded my animations I made sure I wasn't using anything mirrored in mixamo and only mirrored them in unity itself, which seemed to help a little, but it's still giving me some slight issues.