Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Resolved [2022.3.11] Soft Shadows missing when running on any Quest headset

Discussion in 'VR' started by DanjelRicci, Oct 12, 2023.

  1. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    317
    Title is self explanatory. Soft Shadows are only visible in editor, no matter which quality setting is used. These were working regularly until 2022.3.10.
     
  2. ericprovencher

    ericprovencher

    Unity Technologies

    Joined:
    Dec 17, 2020
    Posts:
    336
    Hey so I just looked into this and it seems like you can use soft shadows on Quest, it just requires controlling it via the global URP settings asset. The initial regression to soft shadow performance was caused by per light settings adding branching to the shader code. There's now a fast path for Quest and HoloLens where only the global URP settings are considered.

     
    Last edited: Oct 12, 2023
  3. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    317
    Sorry but I already have that option enabled like that and set on Low. I can't see soft shadows anymore on the Quest build, if they haven't been forced off then it's probably just a new bug on 2022.3.11, because with same identical settings they were working fine in 2022.3.10. I'll delete my tweets about the issue but this has been incredibly misleading and confusing so far, and the changelog about .11 is still empty.

    EDIT: thinking about it, can this be a compatibility issue with Amplify Shader Editor? But again, I can still see them fine in the editor.
     
  4. DanjelRicci

    DanjelRicci

    Joined:
    Mar 8, 2010
    Posts:
    317
    My guess was right, soft shadows are now missing on device due to changes in the pragma keywords that haven't been added yet to Amplify Shader Editor (but an update is coming soon). For anyone interested, to manually fix this, just change this:

    #pragma multi_compile_fragment _ _SHADOWS_SOFT

    Into this:

    #pragma multi_compile_fragment _ _SHADOWS_SOFT _SHADOWS_SOFT_LOW _SHADOWS_SOFT_MEDIUM _SHADOWS_SOFT_HIGH
     
    vertexx likes this.