Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice

2021.2.0b15 unable to build ios due to ITMS-90562: Invalid Bundle

Discussion in '2021.2 Beta' started by IljaDaderko, Oct 12, 2021.

  1. IljaDaderko

    IljaDaderko

    Joined:
    Oct 25, 2019
    Posts:
    7
    I upgraded to 2021.2.0b15 version today, downloaded from unity website not hub. I upgraded from 2021.1.21f1.

    Project ran fine in editor, so I built it to iOS target and deployed to TestFlight (I enabled bytecode), however I am getting following error during TestFlight build processing in the app store connect:

    ITMS-90562: Invalid Bundle - The app cannot be processed because options not allowed to be embedded in bitcode are detected in the submission. It is likely that you are not building the app with the toolchain provided in Xcode. Rebuild your entire app with the latest GM Xcode and submit the app again.

    Nothing besides new unity version changed between this build being successful and now failing. I tired multiple times as well.

    I am working on a:
    macOS 11.6 BigSur / M1 MacBook Air / XCode 13.0
     
  2. Carpet_Head

    Carpet_Head

    Joined:
    Nov 27, 2014
    Posts:
    258
    believe this is caused by burst 1.6.0 rather than the unity beta
     
    sandolkakos likes this.
  3. IljaDaderko

    IljaDaderko

    Joined:
    Oct 25, 2019
    Posts:
    7
    Interesting, I assume unity version difference updates burst in between then? Also @Carper_Head everything works if you don't enable "bytcode" version in XCode.
     
  4. IljaDaderko

    IljaDaderko

    Joined:
    Oct 25, 2019
    Posts:
    7
    Actually, I'm not sure if its related to burst, I can see that 1.6.0 was released on 1st of September, and I was able to build my project with enabled bytecode until I updated to 2021.2 today
     
  5. Kichang-Kim

    Kichang-Kim

    Joined:
    Oct 19, 2010
    Posts:
    1,011
  6. pKallv

    pKallv

    Joined:
    Mar 2, 2014
    Posts:
    1,191
    terence_acodes and ROBYER1 like this.
  7. ROBYER1

    ROBYER1

    Joined:
    Oct 9, 2015
    Posts:
    1,454
    I'm getting the same invalid binary error when using the meshoptimizer decompression Unity plugin which had a dependency on Burst 1.6.0, just updated burst to fix too
     
  8. tolosaoldfan

    tolosaoldfan

    Joined:
    Sep 14, 2012
    Posts:
    92
    Thanks, you saved my day! I confirm the Burst update 1.6->1.6.5 solved the problem.